View Single Post
      09-14-2020, 08:15 PM   #5
Tim2189
Russian in a Bimmer
Tim2189's Avatar
United_States
448
Rep
5,568
Posts

Drives: X5 M50i
Join Date: Jul 2008
Location: Brooklyn NY

iTrader: (3)

Send a message via AIM to Tim2189
Quote:
Originally Posted by Sophisticated Redneck View Post
Remember that Car and Driver uses the 1 foot roll out time and also corrects to sea level. Your DA is only 159ft so there wont be much a correction factor. Looking at the G meter, you had a few tenths of a second delay before it really took off. Most likely this was turbo lag. There was also a sharp drop off after it peaked and interesting wave for the rest of your run, possible being limited by the DME, BMW sets the torque limit lower on the M50i then the M. Can't have you getting too close to the M ya know....You would need a data logger like the JB4 to confirm if this is happening by boost is being pulled.

You can try power braking to eliminate the lag at takeoff since launch control is a mixed bag when it comes to BMW's. If you resolve the delay in the launch, you should be right around 4 seconds 1foot 0-60 time. You might be able to find the missing few tenths by manually shifting at different RPM points.
Manual shifting was even slower, this was the best time i was able to get, with 1 ft roll I guess it's not that bad. That's in sports plus and in sport transmission, traction off
Attached Images
 
__________________
2013 X6 - retired
2015 X6 - retired
2015 435GC - retired
2018 X5 40e - retired
2020 X5 M50i - Current