BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      05-21-2020, 04:36 PM   #1
VTENGR
Major
429
Rep
1,170
Posts

Drives: 2020 X5 M50i
Join Date: Aug 2018
Location: Atlanta

iTrader: (1)

Odd Spotify behavior

If I start Spotify using the iDrive app everything seems to work fine. However if I try to pick a specific song it opens Spotify in Carplay and shows the song playing but with no volume. From that point forward I can't get Spotify to play correctly again. Is anyone else experiencing similar behavior.
Appreciate 1
      05-21-2020, 11:28 PM   #2
russelldav
456bhp for breakfast
russelldav's Avatar
Canada
376
Rep
876
Posts

Drives: 2019 X5 50i
Join Date: Oct 2013
Location: Vancouver, Canada

iTrader: (0)

Glad you posted this I have also experienced the exact same behaviour. I thought it was a CarPlay bug since I got a software update on the vehicle but tonight I was out driving and it suddenly dawned in me this only started after I signed in to the embedded iDrive Spotify app.

I find songs that start playing on CarPlay suddenly stop and then the only way I can get anything to play again is by rebooting iDrive. Pressing play does nothing nor does skip it does load the album art etc but no sound can be heard.

I was going to try signing out of the iDrive app and see if that fixes it.
Appreciate 0
      05-22-2020, 06:14 AM   #3
VTENGR
Major
429
Rep
1,170
Posts

Drives: 2020 X5 M50i
Join Date: Aug 2018
Location: Atlanta

iTrader: (1)

Quote:
Originally Posted by russelldav View Post
Glad you posted this I have also experienced the exact same behaviour. I thought it was a CarPlay bug since I got a software update on the vehicle but tonight I was out driving and it suddenly dawned in me this only started after I signed in to the embedded iDrive Spotify app.

I find songs that start playing on CarPlay suddenly stop and then the only way I can get anything to play again is by rebooting iDrive. Pressing play does nothing nor does skip it does load the album art etc but no sound can be heard.

I was going to try signing out of the iDrive app and see if that fixes it.
My issue seems to be occurring if I've been listening to Spotify on my phone before getting in the car. The iOS app wants to resume playing when the phone connects to Bluetooth. So carplay automatically kicks in. Once that happens the iDrive app will always kick you back to car play and no audio will output eventhough the track is playing. To fix it I just go back to FM radio. However if I want to go back to Spotify I have to do it through car play and not the built in app. Going back to the built in app repeats the issue. I don't remember this being an issue before so I wonder if a recent Spotify update is the culprit.
Appreciate 0
      05-22-2020, 09:51 AM   #4
russelldav
456bhp for breakfast
russelldav's Avatar
Canada
376
Rep
876
Posts

Drives: 2019 X5 50i
Join Date: Oct 2013
Location: Vancouver, Canada

iTrader: (0)

I have solved this (for now) by signing out of the iDrive Spotify app and just using CarPlay. There must be a conflict between the two.

Spotify iOS 8.5.58
iStep 03/2020.30
Appreciate 1
VTENGR429.00

      05-22-2020, 11:31 AM   #5
VTENGR
Major
429
Rep
1,170
Posts

Drives: 2020 X5 M50i
Join Date: Aug 2018
Location: Atlanta

iTrader: (1)

Quote:
Originally Posted by russelldav View Post
I have solved this (for now) by signing out of the iDrive Spotify app and just using CarPlay. There must be a conflict between the two.

Spotify iOS 8.5.58
iStep 03/2020.30
Thanks... I'll try this if it happens again. Kinda sucks b/c I'd rather use the iDrive app since it's integrated in the HUD, etc.

How do you sign out of the iDrive app??
Appreciate 0
      05-22-2020, 09:17 PM   #6
russelldav
456bhp for breakfast
russelldav's Avatar
Canada
376
Rep
876
Posts

Drives: 2019 X5 50i
Join Date: Oct 2013
Location: Vancouver, Canada

iTrader: (0)

Quote:
Originally Posted by VTENGR View Post
Quote:
Originally Posted by russelldav View Post
I have solved this (for now) by signing out of the iDrive Spotify app and just using CarPlay. There must be a conflict between the two.

Spotify iOS 8.5.58
iStep 03/2020.30
Thanks... I'll try this if it happens again. Kinda sucks b/c I'd rather use the iDrive app since it's integrated in the HUD, etc.

How do you sign out of the iDrive app??
Open it and then scroll down to Home and press Options > Logout
Appreciate 0
      05-23-2020, 06:15 AM   #7
VTENGR
Major
429
Rep
1,170
Posts

Drives: 2020 X5 M50i
Join Date: Aug 2018
Location: Atlanta

iTrader: (1)

Quote:
Originally Posted by russelldav View Post
Quote:
Originally Posted by VTENGR View Post
Quote:
Originally Posted by russelldav View Post
I have solved this (for now) by signing out of the iDrive Spotify app and just using CarPlay. There must be a conflict between the two.

Spotify iOS 8.5.58
iStep 03/2020.30
Thanks... I'll try this if it happens again. Kinda sucks b/c I'd rather use the iDrive app since it's integrated in the HUD, etc.

How do you sign out of the iDrive app??
Open it and then scroll down to Home and press Options > Logout
Thanks!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:42 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST