BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      01-14-2019, 11:33 PM   #1
Bollywoodkid
Enlisted Member
7
Rep
32
Posts

Drives: G05
Join Date: Jan 2019
Location: NY

iTrader: (0)

Driver Assistance Support Reduced

Picked up brand new G05.
Driving home from dealer, we get these error messages about "Driver assistance support reduced"
Has anyone got this or did I just get a busted up unit?
Attached Images
 
Appreciate 0
      01-14-2019, 11:35 PM   #2
sb1805
Private First Class
17
Rep
120
Posts

Drives: 2016 M4
Join Date: Dec 2015
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by Bollywoodkid View Post
Picked up brand new G05.
Driving home from dealer, we get these error messages about "Driver assistance support reduced"
Has anyone got this or did I just get a busted up unit?
I get the same thing! Waiting on the big software update before taking the car in to see what the dealership can do about it.
Appreciate 0
      01-14-2019, 11:39 PM   #3
Bollywoodkid
Enlisted Member
7
Rep
32
Posts

Drives: G05
Join Date: Jan 2019
Location: NY

iTrader: (0)

Quote:
Originally Posted by sb1805 View Post
Quote:
Originally Posted by Bollywoodkid View Post
Picked up brand new G05.
Driving home from dealer, we get these error messages about "Driver assistance support reduced"
Has anyone got this or did I just get a busted up unit?
I get the same thing! Waiting on the big software update before taking the car in to see what the dealership can do about it.
It a software or a hardware ?
I'm also waiting around..
Appreciate 0
      01-14-2019, 11:49 PM   #4
mbarrett635
Private First Class
United_States
147
Rep
153
Posts

Drives: 2019 X5 40i
Join Date: Jan 2010
Location: Harrisburg, PA, USA

iTrader: (0)

I used to get messages like that in my previous X5 (F15). They were often caused by sensors that were covered up by muddy water/ice/leaves. The messages would not last more than one or two trips before resetting by themselves. If this isn't occurring for you, I'd take it in to the dealer. It's under warranty, so why wait?
Appreciate 0
      01-15-2019, 12:29 AM   #5
TucErDoc
First Lieutenant
53
Rep
308
Posts

Drives: x5 ans m2
Join Date: Jun 2016
Location: Tucson, AZ

iTrader: (0)

Yeah, Iím getting these. They seem to resolve after about a minute or so. I should probably take it in
Appreciate 0
      01-15-2019, 12:50 AM   #6
Ken6096
Private
Ken6096's Avatar
United_States
56
Rep
95
Posts

Drives: Bmw x5 50i G05 2019
Join Date: Oct 2018
Location: Chicago

iTrader: (0)

I have the same problem when i picked up the car last thursday. Was told my sale reps. On that day and take it back to dealer friday morning. Dealer fixed by resetting program and re upload the software and stated that not sure if the control unit has problem. Once picked up at dealer on Saturday, heavy snow, the same warning show up. After that clean car very well, all sensor working properly but.... there still have these warning show up and gone and the button turn to green. I will wait a lil longer to see the big software update and see if they can fix this.
Appreciate 0
      01-15-2019, 01:09 AM   #7
desirusso
Private
desirusso's Avatar
12
Rep
90
Posts

Drives: 06 E90 SG
Join Date: Jul 2006
Location: SoCal

iTrader: (0)

Garage List
2006 330i  [0.00]
[IMG][/IMG]
I got this today, but we were driving in a lot of rain
Attached Images
 
__________________
2019 X5 M Sport Alpine White
Coffee interior , Matt trim
Appreciate 0
      01-15-2019, 05:05 AM   #8
wrickem
shoots lasers
wrickem's Avatar
1374
Rep
3,393
Posts

Drives: what he wants to
Join Date: Mar 2006
Location: lambertville nj

iTrader: (0)

I have the same exact thing. My dealership worked on it all day, updated software, gave me some really nice gifts, thought they fixed it but said if it happens again, it's a camera and the parts are not available until March.

I got it again the next day and they ordered the camera.

It doesn't bother me too much, I just hit the knob to clear it until next time. I noticed today that when the high beams are in auto, it knocks the auto out until it clears itself and turns green again.
__________________
______________________________________________
Current- '19 X5 , '19 911, 07 M6 ,'17 Jeep Wrangler
Appreciate 0
      01-15-2019, 07:19 PM   #9
verruckt
First Lieutenant
85
Rep
300
Posts

Drives: F82 M4, G05 X5, Gen 2 Raptor
Join Date: May 2015
Location: Florida

iTrader: (0)

I have this. Drove the car off the lot and had it 2 weeks before an appointment. Its been in the shop for a week.

The camera module has a fault and needs replacement from Germany. Im guessing weeks until it comes in.

Contacting BMW NA tonight.

EDIT: Called BMW NA, filed a case. I'm not mad / upset, just disappointed to have a new vehicle be out of service within a month of delivery and not working. It's not right for me and my family to be the guinea pig on this. Is it something that breaks the vehicle completely? No, but not something one should have right out of delivery either. We pay for the vehicle and all of the systems to work correctly. Driver assistance is part of the safety features of the vehicle which we bought it for.

To reiterate what I said in another post - the software simply isn't mature for this car yet. I've heard of more issues than I'd care to with the G05, and I've been in the BMW game / circle for a while... on both sides of the fence...

Last edited by verruckt; 01-15-2019 at 07:48 PM..
Appreciate 1
aman2729.50

      01-15-2019, 07:20 PM   #10
BmwGk
Private First Class
37
Rep
139
Posts

Drives: 2019 X5 40i Msport
Join Date: Dec 2018
Location: NY

iTrader: (0)

Quote:
Originally Posted by desirusso View Post
[IMG][/IMG]
I got this today, but we were driving in a lot of rain
Got the same in heavy rain
Appreciate 0
      01-15-2019, 08:08 PM   #11
heinzena
Second Lieutenant
68
Rep
259
Posts

Drives: 340xi M-Sport
Join Date: Sep 2018
Location: Earth

iTrader: (0)

This happened to me today too
Appreciate 0
      01-15-2019, 08:44 PM   #12
Doc5513
Lieutenant
374
Rep
527
Posts

Drives: X5
Join Date: Aug 2015
Location: Virginia, America

iTrader: (0)

This used to happen to me on my F15....any heavy rain. Not sure it can be prevented.
Appreciate 0
      01-15-2019, 08:45 PM   #13
2019 x5
New Member
6
Rep
23
Posts

Drives: 528xi
Join Date: Oct 2018
Location: pa

iTrader: (0)

Quote:
Originally Posted by Bollywoodkid View Post
Picked up brand new G05.
Driving home from dealer, we get these error messages about "Driver assistance support reduced"
Has anyone got this or did I just get a busted up unit?
i had the same issue since the day i picked it up. Finally went to the dealer Monday. They advised that the bulletin calls for reprogramming and replacement of the camera if the program does not work-it didn't. So, camera are back ordered and they will not have until at least Feb
Appreciate 0
      01-15-2019, 09:09 PM   #14
verruckt
First Lieutenant
85
Rep
300
Posts

Drives: F82 M4, G05 X5, Gen 2 Raptor
Join Date: May 2015
Location: Florida

iTrader: (0)

Quote:
Originally Posted by Doc5513 View Post
This used to happen to me on my F15....any heavy rain. Not sure it can be prevented.
It's not the same thing.
Appreciate 0
      01-15-2019, 09:43 PM   #15
Doc5513
Lieutenant
374
Rep
527
Posts

Drives: X5
Join Date: Aug 2015
Location: Virginia, America

iTrader: (0)

Quote:
Originally Posted by verruckt View Post
Quote:
Originally Posted by Doc5513 View Post
This used to happen to me on my F15....any heavy rain. Not sure it can be prevented.
It's not the same thing.
Ok boss
Appreciate 0
      01-18-2019, 05:15 PM   #16
verruckt
First Lieutenant
85
Rep
300
Posts

Drives: F82 M4, G05 X5, Gen 2 Raptor
Join Date: May 2015
Location: Florida

iTrader: (0)

Just as an update I've been told it will be 3 weeks minimum until the part gets here for my car.

Until then it is at the shop...

Brand new car I'm making payments on, and I can't even drive it
Appreciate 0
      01-18-2019, 05:20 PM   #17
TurtleBoy
Colonel
TurtleBoy's Avatar
1065
Rep
2,571
Posts

Drives: 2019 X5 40i
Join Date: Jan 2019
Location: Colorado

iTrader: (0)

Quote:
Originally Posted by verruckt View Post
Just as an update I've been told it will be 3 weeks minimum until the part gets here for my car.

Until then it is at the shop...

Brand new car I'm making payments on, and I can't even drive it
What type of loaner did they give you?
Appreciate 1
wrickem1374.00

      01-18-2019, 05:22 PM   #18
wrickem
shoots lasers
wrickem's Avatar
1374
Rep
3,393
Posts

Drives: what he wants to
Join Date: Mar 2006
Location: lambertville nj

iTrader: (0)

Quote:
Originally Posted by verruckt View Post
Just as an update I've been told it will be 3 weeks minimum until the part gets here for my car.

Until then it is at the shop...

Brand new car I'm making payments on, and I can't even drive it
Why did they keep your car??! Iíd be mad if they kept my car over something like this. My dealer ordered the camera after they found the update didnít work and sent me home with my car and some very nice BMW gifts. Today they told me the camera still has a March expect date from Germany.
__________________
______________________________________________
Current- '19 X5 , '19 911, 07 M6 ,'17 Jeep Wrangler
Appreciate 0
      01-19-2019, 07:41 PM   #19
verruckt
First Lieutenant
85
Rep
300
Posts

Drives: F82 M4, G05 X5, Gen 2 Raptor
Join Date: May 2015
Location: Florida

iTrader: (0)

Quote:
Originally Posted by TurtleBoy View Post
What type of loaner did they give you?
None at this time. They didn't have any available.

Working on getting one still.
Appreciate 0
      01-19-2019, 07:45 PM   #20
TurtleBoy
Colonel
TurtleBoy's Avatar
1065
Rep
2,571
Posts

Drives: 2019 X5 40i
Join Date: Jan 2019
Location: Colorado

iTrader: (0)

Quote:
Originally Posted by verruckt View Post
None at this time. They didn't have any available.

Working on getting one still.
Wow, sorry to hear that. There is no way they shouldn't be providing you with a very nice loaner.
Appreciate 0
      01-19-2019, 07:50 PM   #21
verruckt
First Lieutenant
85
Rep
300
Posts

Drives: F82 M4, G05 X5, Gen 2 Raptor
Join Date: May 2015
Location: Florida

iTrader: (0)

Quote:
Originally Posted by wrickem View Post
Why did they keep your car??! Iíd be mad if they kept my car over something like this. My dealer ordered the camera after they found the update didnít work and sent me home with my car and some very nice BMW gifts. Today they told me the camera still has a March expect date from Germany.
Not sure really. Initially I only expected a couple day wait, and then found out the part would take 7 days... then 15... and now likely more. I actually called Thursday when i found out it would be 15+ days and asked if I could just pick it up and drive it until the part comes in. They didn't really say no but they didn't say yes either and said they would "try" to get me a loaner.

Between the dealer and BMW NA I'm not really impressed with their response so far. I've had to call each time to get any update. Especially not since I just made my second payment on it and haven't had it for the past week and a half.

To top things off, the wife was driving my truck in lieu of the X5 (X5 is hers), and since shes not comfortable with the size of it, managed to accidentally back into someone today... ....It just gets better and better.
Appreciate 0
      01-19-2019, 08:11 PM   #22
mnewnam
First Lieutenant
165
Rep
349
Posts

Drives: '19 Mineral White X5 40i
Join Date: Feb 2014
Location: Houston, TX

iTrader: (0)

Quote:
Originally Posted by verruckt View Post
Quote:
Originally Posted by wrickem View Post
Why did they keep your car??! I'd be mad if they kept my car over something like this. My dealer ordered the camera after they found the update didn't work and sent me home with my car and some very nice BMW gifts. Today they told me the camera still has a March expect date from Germany.
Not sure really. Initially I only expected a couple day wait, and then found out the part would take 7 days... then 15... and now likely more. I actually called Thursday when i found out it would be 15+ days and asked if I could just pick it up and drive it until the part comes in. They didn't really say no but they didn't say yes either and said they would "try" to get me a loaner.

Between the dealer and BMW NA I'm not really impressed with their response so far. I've had to call each time to get any update. Especially not since I just made my second payment on it and haven't had it for the past week and a half.

To top things off, the wife was driving my truck in lieu of the X5 (X5 is hers), and since shes not comfortable with the size of it, managed to accidentally back into someone today... ....It just gets better and better.
Yeah... when mine broke down and became undriveable 7 days and 300 miles after purchase the lack of communication from BMW NA, my selling dealer, and the repairing dealer that had it a couple hundred miles away was so annoying.

I got one call from BMW NA which I thought went well. I then didn't hear anything back for a week. They did not offer me a loaner but continued to pay for the Chevrolet Suburban I ended up renting in Louisiana.

The repairing dealer didn't update me for 2 days and didn't return my call each day to check on the status. Even if there's no new info, just tell me that. I just want communication. What made it worse is through the BMW Connected app I could see the car hadn't been touched since it was towed there the Saturday before.

I reached out to my CA for help and he didn't respond. I had to end up emailing him and copying the dealer manager asking them to return my funds and I'll get another one later on. Within an hour I had calls from everyone involved. Dealer manager at the selling dealer said she called the dealership manager of the repairing dealer... CA called me back to offer me a new X5 if it couldn't be repaired soon. Next day they had it fixed and on a flatbed back to me, which was about a week since we broke down.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:12 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST