BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      12-07-2019, 12:59 PM   #1
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

I purchased a Dinantronics Sport for my incoming X5 40i. Got a great deal on it during black Friday. Was led to believe it would work on the G05 (description online and box only says B58).

Does anyone have any experience with it? Also reaching out to Dinan.
__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 0
      12-07-2019, 05:15 PM   #2
dubsesd
OEM++
dubsesd's Avatar
No_Country
5386
Rep
5,109
Posts

Drives: F15 X5 MP/ 2016 F80 M3 INDVL
Join Date: Jul 2011
Location: Ottawa

iTrader: (2)

i suggest waiting for protuningfreaks flash tune. i just ran it for 4 weeks doing beta testing and its amazing. smooth, predictable, and customizable for gts startup sequence, burble and overrun, boost by gear, max cooling feature and many more...
__________________
LCI ///F80 M3 Individual Atlantis Metallic / Black Full / Carbon Cermics / 6MT
MPE / M Performance & Carbon package / KW v3 / 20" HRE R101LW / 20" HRE 527s / Michelin PSS / 20% tint / 3d Design / Streckenn splitters / OEM GTS hood / EAS Carbon seatbacks / Carbon RKP sideskirt / Bootmod3 / M Performance Tri color alcantara / AWE S Flow
instagram: @ dubsesd
Appreciate 0
      12-09-2019, 10:51 AM   #3
subzero05
Private First Class
92
Rep
187
Posts

Drives: 2007 335
Join Date: Feb 2015
Location: california

iTrader: (0)

Quote:
Originally Posted by teefive View Post
I purchased a Dinantronics Sport for my incoming X5 40i. Got a great deal on it during black Friday. Was led to believe it would work on the G05 (description online and box only says B58).

Does anyone have any experience with it? Also reaching out to Dinan.
yep not sure if it works on that application or not? You can always contact Ben @ RG on here and see if he can work you up a deal on a RaceChip unit? I know they have one and it wont void your warranty like a flash will.
Appreciate 1
      12-09-2019, 06:26 PM   #4
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

Response from Dinan:

In theory as long as its using the same physical connector it should work but we have not verified fitment on the B58 X5 40i so could not guarantee compatibility.
__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 0
      12-11-2019, 11:48 AM   #5
duman81
Private First Class
duman81's Avatar
28
Rep
118
Posts

Drives: 2015 F82
Join Date: Apr 2018
Location: Fort Lauderdale

iTrader: (1)

dubsesd

Do you have any videos on the sound/performance for the beta? Is your G05 40i?
__________________
P
Appreciate 0
      12-19-2019, 09:32 AM   #6
subzero05
Private First Class
92
Rep
187
Posts

Drives: 2007 335
Join Date: Feb 2015
Location: california

iTrader: (0)

Quote:
Originally Posted by teefive View Post
Response from Dinan:

In theory as long as its using the same physical connector it should work but we have not verified fitment on the B58 X5 40i so could not guarantee compatibility.

so what did you decide to do on this?
Appreciate 0
      12-19-2019, 07:00 PM   #7
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

I have about 450 miles on my X5 (picked up last week). waiting until it's broken in to try it out. ill update this thread with experiences
__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 0
      01-04-2020, 05:06 PM   #8
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

I have about 1100 miles and installed this today. Takes 10 minutes (tops) -- two connections on the top of engine (just need to remove the engine cover).

Drove it around the neighborhood and it felt noticeably snappier. No issues to report. Will write a more detailed review after the weekend. So far, great $200 mod.
__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 0
      01-30-2020, 08:39 PM   #9
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

A member PM'd me for my experience and here's my response. I have 2000 miles on the car and 900 miles on the tune.

-----

Quote:
Originally Posted by Stealthall
What are your thoughts now on the Dinan after driving for a couple weeks?
Very pleased.

Price: Dirt cheap ... paid $200 with a coupon code
Install: Less than 5 minutes. Remove engine cover and bypasses two connections on the top of the engine. No tools required.

Impressions: Noticeable boost in power. No Check Engine lights or anything. Engine felt a little jumpy for the first 50 miles or so ... now it's smooth as stock.

The app allows you to toggle between different boost levels. I left it on the default setting (believe it boosts by 3psi) because I'm running 91 octane.

Overall would recommend. A little extra punch for very little money. Very happy with the B58.
__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 1
LexxM3954.50

      01-31-2020, 12:07 AM   #10
LexxM3
Lieutenant Colonel
LexxM3's Avatar
Canada
955
Rep
1,612
Posts

Drives: E46M3, G05X5
Join Date: Apr 2019
Location: Waterloo, Canada

iTrader: (0)

Garage List
2019 X5  [0.00]
Quote:
Originally Posted by teefive View Post
A member PM'd me for my experience and here's my response. I have 2000 miles on the car and 900 miles on the tune.

-----

Quote:
Originally Posted by Stealthall
What are your thoughts now on the Dinan after driving for a couple weeks?
Very pleased.

Price: Dirt cheap ... paid $200 with a coupon code
Install: Less than 5 minutes. Remove engine cover and bypasses two connections on the top of the engine. No tools required.

Impressions: Noticeable boost in power. No Check Engine lights or anything. Engine felt a little jumpy for the first 50 miles or so ... now it's smooth as stock.

The app allows you to toggle between different boost levels. I left it on the default setting (believe it boosts by 3psi) because I'm running 91 octane.

Overall would recommend. A little extra punch for very little money. Very happy with the B58.
Nice. Is this the D440-0047 model?
__________________
G05 X5 x40i (04/2019 mfg, Canada) on S18A-19-11-540
Appreciate 0
      01-31-2020, 06:38 AM   #11
Stealthall
Private
6
Rep
51
Posts

Drives: BMW X5 40i
Join Date: Nov 2019
Location: Raleigh NC

iTrader: (0)

Quote:
Originally Posted by teefive View Post
A member PM'd me for my experience and here's my response. I have 2000 miles on the car and 900 miles on the tune.

-----

Quote:
Originally Posted by Stealthall
What are your thoughts now on the Dinan after driving for a couple weeks?
Very pleased.

Price: Dirt cheap ... paid $200 with a coupon code
Install: Less than 5 minutes. Remove engine cover and bypasses two connections on the top of the engine. No tools required.

Impressions: Noticeable boost in power. No Check Engine lights or anything. Engine felt a little jumpy for the first 50 miles or so ... now it's smooth as stock.

The app allows you to toggle between different boost levels. I left it on the default setting (believe it boosts by 3psi) because I'm running 91 octane.

Overall would recommend. A little extra punch for very little money. Very happy with the B58.
Quote:
Originally Posted by teefive View Post
A member PM'd me for my experience and here's my response. I have 2000 miles on the car and 900 miles on the tune.

-----

Quote:
Originally Posted by Stealthall
What are your thoughts now on the Dinan after driving for a couple weeks?
Very pleased.

Price: Dirt cheap ... paid $200 with a coupon code
Install: Less than 5 minutes. Remove engine cover and bypasses two connections on the top of the engine. No tools required.

Impressions: Noticeable boost in power. No Check Engine lights or anything. Engine felt a little jumpy for the first 50 miles or so ... now it's smooth as stock.

The app allows you to toggle between different boost levels. I left it on the default setting (believe it boosts by 3psi) because I'm running 91 octane.

Overall would recommend. A little extra punch for very little money. Very happy with the B58.

Thanks for responding.

I guess we don't really know the HP and TQ increases. I am probably going to pull the trigger on the Bootmod3, however If this tune was delivering 40+ HP & TQ under 93 gas it would probably make more sense.
Appreciate 0
      01-31-2020, 08:12 AM   #12
x5_M50i_NC
Enlisted Member
20
Rep
41
Posts

Drives: 2017 BMW 540ix / 2020 X5 M50i
Join Date: Dec 2019
Location: NC

iTrader: (0)

I'm getting ready to sell my Stage 1 Dinan D440-D830 tune (Had it on my B58 540xi and i'm moving to an X5 M50). I was very pleased with the increased performance. If anybody is interested I'll sell it to a member for cheap. Beats putting it on eBay.
Appreciate 0
      01-31-2020, 10:17 AM   #13
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by teefive View Post
A member PM'd me for my experience and here's my response. I have 2000 miles on the car and 900 miles on the tune.

-----

Quote:
Originally Posted by Stealthall
What are your thoughts now on the Dinan after driving for a couple weeks?
Very pleased.

Price: Dirt cheap ... paid $200 with a coupon code
Install: Less than 5 minutes. Remove engine cover and bypasses two connections on the top of the engine. No tools required.

Impressions: Noticeable boost in power. No Check Engine lights or anything. Engine felt a little jumpy for the first 50 miles or so ... now it's smooth as stock.

The app allows you to toggle between different boost levels. I left it on the default setting (believe it boosts by 3psi) because I'm running 91 octane.

Overall would recommend. A little extra punch for very little money. Very happy with the B58.
Nice. Is this the D440-0047 model?
Yes it is
__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 1
LexxM3954.50

      02-02-2020, 06:02 PM   #14
LexxM3
Lieutenant Colonel
LexxM3's Avatar
Canada
955
Rep
1,612
Posts

Drives: E46M3, G05X5
Join Date: Apr 2019
Location: Waterloo, Canada

iTrader: (0)

Garage List
2019 X5  [0.00]
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Nice. Is this the D440-0047 model?
Yes it is
Nice. Can you please also verify that pictured are the two connection points on the G05 40i engine? Dinan pics are not particularly high resolution and of slightly different wiring layout engines.
Attached Images
  
__________________
G05 X5 x40i (04/2019 mfg, Canada) on S18A-19-11-540
Appreciate 0
      02-02-2020, 09:43 PM   #15
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Nice. Is this the D440-0047 model?
Yes it is
Nice. Can you please also verify that pictured are the two connection points on the G05 40i engine? Dinan pics are not particularly high resolution and of slightly different wiring layout engines.
See attached. Connections are circled red, mounting point is green.
Attached Images
 
__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 1
LexxM3954.50

      02-03-2020, 09:54 PM   #16
LexxM3
Lieutenant Colonel
LexxM3's Avatar
Canada
955
Rep
1,612
Posts

Drives: E46M3, G05X5
Join Date: Apr 2019
Location: Waterloo, Canada

iTrader: (0)

Garage List
2019 X5  [0.00]
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Nice. Is this the D440-0047 model?
Yes it is
Nice. Can you please also verify that pictured are the two connection points on the G05 40i engine? Dinan pics are not particularly high resolution and of slightly different wiring layout engines.
See attached. Connections are circled red, mounting point is green.
Ok, thanks. The pic still came out pretty low res and hard to tell which of the two front connectors it is, but I'll figure it out. Mine should be in by the weekend. Thanks for posting your experience!
__________________
G05 X5 x40i (04/2019 mfg, Canada) on S18A-19-11-540
Appreciate 1
teefive150.50

      02-04-2020, 05:48 AM   #17
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Nice. Is this the D440-0047 model?
Yes it is
Nice. Can you please also verify that pictured are the two connection points on the G05 40i engine? Dinan pics are not particularly high resolution and of slightly different wiring layout engines.
See attached. Connections are circled red, mounting point is green.
Ok, thanks. The pic still came out pretty low res and hard to tell which of the two front connectors it is, but I'll figure it out. Mine should be in by the weekend. Thanks for posting your experience!
This is a video that helped me too. Same connections as the Dinan unit.

__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 1
LexxM3954.50

      02-04-2020, 08:04 AM   #18
LexxM3
Lieutenant Colonel
LexxM3's Avatar
Canada
955
Rep
1,612
Posts

Drives: E46M3, G05X5
Join Date: Apr 2019
Location: Waterloo, Canada

iTrader: (0)

Garage List
2019 X5  [0.00]
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Nice. Is this the D440-0047 model?
Yes it is
Nice. Can you please also verify that pictured are the two connection points on the G05 40i engine? Dinan pics are not particularly high resolution and of slightly different wiring layout engines.
See attached. Connections are circled red, mounting point is green.
Ok, thanks. The pic still came out pretty low res and hard to tell which of the two front connectors it is, but I'll figure it out. Mine should be in by the weekend. Thanks for posting your experience!
This is a video that helped me too. Same connections as the Dinan unit.

That answers the question!

Interestingly I did watch that exact video before popping the hood, but neglected to watch it again once I got myself oriented in that ducting/wiring mess under the cover, so this reminder was very helpful.

And I now finally understand why modern engines have covers — not just to "make customer feel comfortable", but to hide and protect the mess under it (X5 is my first car with an engine cover).
__________________
G05 X5 x40i (04/2019 mfg, Canada) on S18A-19-11-540
Appreciate 1
teefive150.50

      02-07-2020, 08:29 AM   #19
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Nice. Is this the D440-0047 model?
Yes it is
Nice. Can you please also verify that pictured are the two connection points on the G05 40i engine? Dinan pics are not particularly high resolution and of slightly different wiring layout engines.
See attached. Connections are circled red, mounting point is green.
Ok, thanks. The pic still came out pretty low res and hard to tell which of the two front connectors it is, but I'll figure it out. Mine should be in by the weekend. Thanks for posting your experience!
Interested to hear your experience. Keep us updated!
__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 0
      02-10-2020, 06:45 PM   #20
LexxM3
Lieutenant Colonel
LexxM3's Avatar
Canada
955
Rep
1,612
Posts

Drives: E46M3, G05X5
Join Date: Apr 2019
Location: Waterloo, Canada

iTrader: (0)

Garage List
2019 X5  [0.00]
Quote:
Originally Posted by teefive View Post
Interested to hear your experience. Keep us updated!
Well, my first try at this didn't go as smoothly as yours. Received the unit on Sat morning, D440-0047, everything looks right. Hood up, car locked, take the key far away, wait 15min. Install harness in the two spots (3pin near the front, 4 pin in the middle), tie wrap everything. Car on, engine off, the unit LED lights up and ... everything from then on went badly. Summary:
  • the D-SPORT app on iOS mostly wouldn't find the unit at all (just sits there scanning for BT devices, finding nothing); but when it did find it and switched to an intro splash screen, it then immediately crashed within 0.5-1 seconds; tried reboots, swipe aways, re-installs ... on 3 different iPhone models (6, 8, and XR) with 3 different iOS versions (12.4.3, 13.3, and 13.3.1)
  • started engine, car idled rough then settled down after a few seconds; but if you give it a little revs (even below 3000 rpm), wouldn't spin up, be very rough, or even stalled a few times
  • decided to go slow around the block; CEL blaring, continuous stalling, barely made it back to the garage
Obviously I immediately removed it; car went back to normal, but I now have "permanent" CEL "boost pressure too high" codes everywhere.

Discussed with Dinan, they assert it's a defective unit and we've arranged for my local distributor to get a replacement, should be in next weekend. That's good customer service, even on the weekend! But I sure hope it was a rare defect, was really looking forward to a simple gentle boost to stock. Wondering what warranty impact the CEL codes will have if there is an issue. Will report back after next weekend.
Appreciate 0
      02-10-2020, 06:59 PM   #21
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by teefive View Post
Interested to hear your experience. Keep us updated!
Well, my first try at this didn't go as smoothly as yours. Received the unit on Sat morning, D440-0047, everything looks right. Hood up, car locked, take the key far away, wait 15min. Install harness in the two spots (3pin near the front, 4 pin in the middle), tie wrap everything. Car on, engine off, the unit LED lights up and ... everything from then on went badly. Summary:
  • the D-SPORT app on iOS mostly wouldn't find the unit at all (just sits there scanning for BT devices, finding nothing); but when it did find it and switched to an intro splash screen, it then immediately crashed within 0.5-1 seconds; tried reboots, swipe aways, re-installs ... on 3 different iPhone models (6, 8, and XR) with 3 different iOS versions (12.4.3, 13.3, and 13.3.1)
  • started engine, car idled rough then settled down after a few seconds; but if you give it a little revs (even below 3000 rpm), wouldn't spin up, be very rough, or even stalled a few times
  • decided to go slow around the block; CEL blaring, continuous stalling, barely made it back to the garage
Obviously I immediately removed it; car went back to normal, but I now have "permanent" CEL "boost pressure too high" codes everywhere.

Discussed with Dinan, they assert it's a defective unit and we've arranged for the my local distributor to get a replacement, should be in next weekend. That's good customer service, even on the weekend! But I sure hope it was a rare defect, was really looking forward to a simple gentle boost to stock. Wondering what warranty impact the CEL codes will have if there is an issue. Will report back after next weekend.
Sorry to hear. My guess is the CEL will clear on it's own after some driving cycles. That's how my F80 behaved when it had a piggyback it didn't like (ESS).

The app does indeed suck fwiw. It doesn't work on my latest Android decide (OnePlus 7 Pro). Works better on my older Galaxy S8 ... but feels like an app from 10 years ago.
__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 1
LexxM3954.50

      03-02-2020, 12:53 PM   #22
bichoo
Lieutenant
bichoo's Avatar
Canada
254
Rep
482
Posts

Drives: BMW X5 40i M-Sport
Join Date: Sep 2012
Location: Ottawa, Canada

iTrader: (0)

Quote:
Originally Posted by LexxM3 View Post
Well, my first try at this didn't go as smoothly as yours. Received the unit on Sat morning, D440-0047, everything looks right. Hood up, car locked, take the key far away, wait 15min. Install harness in the two spots (3pin near the front, 4 pin in the middle), tie wrap everything. Car on, engine off, the unit LED lights up and ... everything from then on went badly. Summary:
  • the D-SPORT app on iOS mostly wouldn't find the unit at all (just sits there scanning for BT devices, finding nothing); but when it did find it and switched to an intro splash screen, it then immediately crashed within 0.5-1 seconds; tried reboots, swipe aways, re-installs ... on 3 different iPhone models (6, 8, and XR) with 3 different iOS versions (12.4.3, 13.3, and 13.3.1)
  • started engine, car idled rough then settled down after a few seconds; but if you give it a little revs (even below 3000 rpm), wouldn't spin up, be very rough, or even stalled a few times
  • decided to go slow around the block; CEL blaring, continuous stalling, barely made it back to the garage
Obviously I immediately removed it; car went back to normal, but I now have "permanent" CEL "boost pressure too high" codes everywhere.

Discussed with Dinan, they assert it's a defective unit and we've arranged for my local distributor to get a replacement, should be in next weekend. That's good customer service, even on the weekend! But I sure hope it was a rare defect, was really looking forward to a simple gentle boost to stock. Wondering what warranty impact the CEL codes will have if there is an issue. Will report back after next weekend.
did you get a replacement yet from Dinan and try it out?
__________________
2019 BMW X5 40i Phytonic Blue/Tartufo
2016 BMW X3 35i M-Sport, Dinantronics (sold)
2012 BMW X3 28i (sold)
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:14 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST