BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      09-16-2019, 01:59 PM   #1
Aimster82
Second Lieutenant
59
Rep
279
Posts

Drives: 2018 X3 M40i 2019 BMW X5 5.0
Join Date: Apr 2018
Location: Virginia

iTrader: (0)

Speakers - All distorted

BIMMERPOST
     Featured on BIMMERPOST.com
All my speakers are distorted. I turned the car on and off but nothing happened. What could be causing this?

I have the Bowers and Wilkins sound system.

So much for me saying I have no issues with my X5...
Appreciate 0
      09-16-2019, 02:08 PM   #2
dan321
Lieutenant
United_States
165
Rep
506
Posts

Drives: 2020 X5 40i
Join Date: Aug 2018
Location: Central FL

iTrader: (0)

If all the speakers are distorted it is probably a problem in the audio electronics. Just in case though, have you rebooted iDrive (press on the volume knob for at least 20 seconds)?

But most likely you will have to make a trip to the dealer.
Appreciate 0
      09-16-2019, 02:09 PM   #3
JFU
Lieutenant
United_States
112
Rep
457
Posts

Drives: X7
Join Date: Apr 2009
Location: Boston, MA

iTrader: (3)

Quote:
Originally Posted by Aimster82 View Post
All my speakers are distorted. I turned the car on and off but nothing happened. What could be causing this?

I have the Bowers and Wilkins sound system.

So much for me saying I have no issues with my X5...
What kind of distortion? Could be the amp is on its way out if you are still getting sound.
__________________
2014 A207 E550 Vert
2018 F60 Countryman S All4
2019 G07 X7 40i
Appreciate 0
      09-16-2019, 02:24 PM   #4
Aimster82
Second Lieutenant
59
Rep
279
Posts

Drives: 2018 X3 M40i 2019 BMW X5 5.0
Join Date: Apr 2018
Location: Virginia

iTrader: (0)

Powers been reduced to about 10% and the sound is echoing and full of static. At first I thought my Bluetooth was playing audio at the same time as the USB.
Appreciate 0
      09-16-2019, 04:03 PM   #5
AndroidRobot
Brigadier General
AndroidRobot's Avatar
United_States
2032
Rep
4,546
Posts

Drives: 2019 X5 50i Carbon/Tartufo
Join Date: Apr 2018
Location: Texas

iTrader: (0)

Mine has been fine since I got the car and I've tested it all the way to Max volume (ear shattering) no distortion at all. I use FLAC audio via a flash drive and some I put on the cars media storage.
__________________
2019 BMW X5 50i Carbon Black/Tartufo
G05 X5 50i Review
G01 X3 M40i/MKII Audi SQ5 Comparison
Appreciate 0
      09-16-2019, 05:47 PM   #6
ggalanis
Second Lieutenant
Canada
149
Rep
273
Posts

Drives: 2019 X5 40i
Join Date: Jan 2016
Location: Montreal

iTrader: (0)

Quote:
Originally Posted by Aimster82 View Post
All my speakers are distorted. I turned the car on and off but nothing happened. What could be causing this?

I have the Bowers and Wilkins sound system.

So much for me saying I have no issues with my X5...
I had something like that happen. Lasted like half a day and the problem went away on its own and never happened again.

The only benefit was that I was able to determine that bmw pumped in engine sound even in comfort mode because even the engine sound came out mangled.

I have a video somewhere.... I'll try to post it to see if it is the same as your issue.

GG
Appreciate 0
      09-16-2019, 08:23 PM   #7
ggalanis
Second Lieutenant
Canada
149
Rep
273
Posts

Drives: 2019 X5 40i
Join Date: Jan 2016
Location: Montreal

iTrader: (0)

Quote:
Originally Posted by Aimster82 View Post
Powers been reduced to about 10% and the sound is echoing and full of static. At first I thought my Bluetooth was playing audio at the same time as the USB.
Is this what it sounded like?

http://www.youtube.com/watch?v=8x1RZjqCfhY


sound is not great (i believe we had the windows open)but you get the idea. I was adding commentary as i thought i would have to send the video to my SA but it went away by itself.

Last edited by ggalanis; 09-16-2019 at 08:27 PM.. Reason: added text
Appreciate 0
      09-16-2019, 09:05 PM   #8
Aimster82
Second Lieutenant
59
Rep
279
Posts

Drives: 2018 X3 M40i 2019 BMW X5 5.0
Join Date: Apr 2018
Location: Virginia

iTrader: (0)

Quote:
Originally Posted by ggalanis View Post
Is this what it sounded like?

http://www.youtube.com/watch?v=8x1RZjqCfhY


sound is not great (i believe we had the windows open)but you get the idea. I was adding commentary as i thought i would have to send the video to my SA but it went away by itself.
Yes!!

It happened as soon as I put it in sport plus mode.

It went away and now it is back to normal. Whew! I am assuming it has to do with the fake engine noise.

I need to disable this. I disabled it on my X3 and the audio system actually improved.
Appreciate 0
      09-16-2019, 10:00 PM   #9
Fuzzy Master
Private
Fuzzy Master's Avatar
Canada
25
Rep
72
Posts

Drives: BMW X5
Join Date: Feb 2019
Location: Richmond Hill

iTrader: (0)

Quote:
Originally Posted by Aimster82 View Post
Yes!!

It happened as soon as I put it in sport plus mode.

It went away and now it is back to normal. Whew! I am assuming it has to do with the fake engine noise.

I need to disable this. I disabled it on my X3 and the audio system actually improved.
Do you have to code to turn off the piped engine sound or is it an iDrive option that can simply be turned off?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:32 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST