BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      03-02-2020, 01:00 PM   #23
LexxM3
Lieutenant Colonel
LexxM3's Avatar
Canada
959
Rep
1,619
Posts

Drives: E46M3, G05X5
Join Date: Apr 2019
Location: Waterloo, Canada

iTrader: (0)

Garage List
2019 X5  [0.00]
Quote:
Originally Posted by bichoo View Post
Quote:
Originally Posted by LexxM3 View Post
Well, my first try at this didn't go as smoothly as yours. Received the unit on Sat morning, D440-0047, everything looks right. Hood up, car locked, take the key far away, wait 15min. Install harness in the two spots (3pin near the front, 4 pin in the middle), tie wrap everything. Car on, engine off, the unit LED lights up and ... everything from then on went badly. Summary:
  • the D-SPORT app on iOS mostly wouldn't find the unit at all (just sits there scanning for BT devices, finding nothing); but when it did find it and switched to an intro splash screen, it then immediately crashed within 0.5-1 seconds; tried reboots, swipe aways, re-installs ... on 3 different iPhone models (6, 8, and XR) with 3 different iOS versions (12.4.3, 13.3, and 13.3.1)
  • started engine, car idled rough then settled down after a few seconds; but if you give it a little revs (even below 3000 rpm), wouldn't spin up, be very rough, or even stalled a few times
  • decided to go slow around the block; CEL blaring, continuous stalling, barely made it back to the garage
Obviously I immediately removed it; car went back to normal, but I now have "permanent" CEL "boost pressure too high" codes everywhere.

Discussed with Dinan, they assert it's a defective unit and we've arranged for my local distributor to get a replacement, should be in next weekend. That's good customer service, even on the weekend! But I sure hope it was a rare defect, was really looking forward to a simple gentle boost to stock. Wondering what warranty impact the CEL codes will have if there is an issue. Will report back after next weekend.
did you get a replacement yet from Dinan and try it out?
Yes, just resolved this weekend. I will find the time for the big/full story, but summary:

- don't buy without attention to source and date/time stamps on the unit (part number/UPC/model are NOT sufficient due to massive Dinan logistics screw up)

- when/if you receive the actually right ordered unit, it's easy and it appears to work :-)
__________________
G05 X5 x40i (04/2019 mfg, Canada) on S18A-19-11-540
Appreciate 1
teefive150.50

      03-02-2020, 06:33 PM   #24
Stealthall
Private
6
Rep
51
Posts

Drives: BMW X5 40i
Join Date: Nov 2019
Location: Raleigh NC

iTrader: (0)

Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by bichoo View Post
Quote:
Originally Posted by LexxM3 View Post
Well, my first try at this didn't go as smoothly as yours. Received the unit on Sat morning, D440-0047, everything looks right. Hood up, car locked, take the key far away, wait 15min. Install harness in the two spots (3pin near the front, 4 pin in the middle), tie wrap everything. Car on, engine off, the unit LED lights up and ... everything from then on went badly. Summary:
  • the D-SPORT app on iOS mostly wouldn't find the unit at all (just sits there scanning for BT devices, finding nothing); but when it did find it and switched to an intro splash screen, it then immediately crashed within 0.5-1 seconds; tried reboots, swipe aways, re-installs ... on 3 different iPhone models (6, 8, and XR) with 3 different iOS versions (12.4.3, 13.3, and 13.3.1)
  • started engine, car idled rough then settled down after a few seconds; but if you give it a little revs (even below 3000 rpm), wouldn't spin up, be very rough, or even stalled a few times
  • decided to go slow around the block; CEL blaring, continuous stalling, barely made it back to the garage
Obviously I immediately removed it; car went back to normal, but I now have "permanent" CEL "boost pressure too high" codes everywhere.

Discussed with Dinan, they assert it's a defective unit and we've arranged for my local distributor to get a replacement, should be in next weekend. That's good customer service, even on the weekend! But I sure hope it was a rare defect, was really looking forward to a simple gentle boost to stock. Wondering what warranty impact the CEL codes will have if there is an issue. Will report back after next weekend.
did you get a replacement yet from Dinan and try it out?
Yes, just resolved this weekend. I will find the time for the big/full story, but summary:

- don't buy without attention to source and date/time stamps on the unit (part number/UPC/model are NOT sufficient due to massive Dinan logistics screw up)

- when/if you receive the actually right ordered unit, it's easy and it appears to work :-)
Installed my DINAN and BMS intake. It's a nice amount of extra punch to tie me over until the tuners crack the Nov software upgrade.
Appreciate 1
teefive150.50

      03-07-2020, 12:23 PM   #25
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by bichoo View Post
Quote:
Originally Posted by LexxM3 View Post
Well, my first try at this didn't go as smoothly as yours. Received the unit on Sat morning, D440-0047, everything looks right. Hood up, car locked, take the key far away, wait 15min. Install harness in the two spots (3pin near the front, 4 pin in the middle), tie wrap everything. Car on, engine off, the unit LED lights up and ... everything from then on went badly. Summary:
  • the D-SPORT app on iOS mostly wouldn't find the unit at all (just sits there scanning for BT devices, finding nothing); but when it did find it and switched to an intro splash screen, it then immediately crashed within 0.5-1 seconds; tried reboots, swipe aways, re-installs ... on 3 different iPhone models (6, 8, and XR) with 3 different iOS versions (12.4.3, 13.3, and 13.3.1)
  • started engine, car idled rough then settled down after a few seconds; but if you give it a little revs (even below 3000 rpm), wouldn't spin up, be very rough, or even stalled a few times
  • decided to go slow around the block; CEL blaring, continuous stalling, barely made it back to the garage
Obviously I immediately removed it; car went back to normal, but I now have "permanent" CEL "boost pressure too high" codes everywhere.

Discussed with Dinan, they assert it's a defective unit and we've arranged for my local distributor to get a replacement, should be in next weekend. That's good customer service, even on the weekend! But I sure hope it was a rare defect, was really looking forward to a simple gentle boost to stock. Wondering what warranty impact the CEL codes will have if there is an issue. Will report back after next weekend.
did you get a replacement yet from Dinan and try it out?
Yes, just resolved this weekend. I will find the time for the big/full story, but summary:

- don't buy without attention to source and date/time stamps on the unit (part number/UPC/model are NOT sufficient due to massive Dinan logistics screw up)

- when/if you receive the actually right ordered unit, it's easy and it appears to work :-)
How's the tune treating you?
__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 0
      03-07-2020, 12:43 PM   #26
CMBX23
Private First Class
CMBX23's Avatar
32
Rep
110
Posts

Drives: 19' X5 50 M-Sport
Join Date: Jan 2020
Location: CT/NY

iTrader: (0)

Garage List
Anyone know of any good intakes for g05 50?
Appreciate 0
      03-10-2020, 09:50 AM   #27
LexxM3
Lieutenant Colonel
LexxM3's Avatar
Canada
959
Rep
1,619
Posts

Drives: E46M3, G05X5
Join Date: Apr 2019
Location: Waterloo, Canada

iTrader: (0)

Garage List
2019 X5  [0.00]
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by bichoo View Post
Quote:
Originally Posted by LexxM3 View Post
Well, my first try at this didn't go as smoothly as yours. Received the unit on Sat morning, D440-0047, everything looks right. Hood up, car locked, take the key far away, wait 15min. Install harness in the two spots (3pin near the front, 4 pin in the middle), tie wrap everything. Car on, engine off, the unit LED lights up and ... everything from then on went badly. Summary:
  • the D-SPORT app on iOS mostly wouldn't find the unit at all (just sits there scanning for BT devices, finding nothing); but when it did find it and switched to an intro splash screen, it then immediately crashed within 0.5-1 seconds; tried reboots, swipe aways, re-installs ... on 3 different iPhone models (6, 8, and XR) with 3 different iOS versions (12.4.3, 13.3, and 13.3.1)
  • started engine, car idled rough then settled down after a few seconds; but if you give it a little revs (even below 3000 rpm), wouldn't spin up, be very rough, or even stalled a few times
  • decided to go slow around the block; CEL blaring, continuous stalling, barely made it back to the garage
Obviously I immediately removed it; car went back to normal, but I now have "permanent" CEL "boost pressure too high" codes everywhere.

Discussed with Dinan, they assert it's a defective unit and we've arranged for my local distributor to get a replacement, should be in next weekend. That's good customer service, even on the weekend! But I sure hope it was a rare defect, was really looking forward to a simple gentle boost to stock. Wondering what warranty impact the CEL codes will have if there is an issue. Will report back after next weekend.
did you get a replacement yet from Dinan and try it out?
Yes, just resolved this weekend. I will find the time for the big/full story, but summary:

- don't buy without attention to source and date/time stamps on the unit (part number/UPC/model are NOT sufficient due to massive Dinan logistics screw up)

- when/if you receive the actually right ordered unit, it's easy and it appears to work :-)
How's the tune treating you?
Third unit was the charm. Once I received the right unit, it works great. I am still getting used to it and will do some app-level "dyno" runs (using PerfExpert app after careful/proper setup) in different modes and then with it out when the car is in for service, but I am pretty happy after a couple of days of engine self-calibration on Race mode with 93 octane fuel. It's not a massive increase, but feels good and stock-smooth. App works both on Android and modern iOS when it connects to a unit that actually works and has Bluetooth inside.

Thank you teefive, literally could not have done it without you!

Now for the PSA ... Dinan has some shit broken units out there in the supply chain; it's unbelievable that Dinan has allowed this, but believe it. If anyone wants to buy one of these, call your supplier and make sure of two things BEFORE allowing them to ship to you: a) the package and unit manufacture dates are both 2019 or later (not 2017) and b) the unit label has a proper Bluetooth MAC address (not all 00:00:00:00:00:00).

See pics below. The 2017 and 00:00 MAC are NON-FUNCTIONAL and there appear to be plenty of these on the shelves (the large distributor for my shop has now pulled all of these off their shelves as a result of my ordeal). The 2019 and non-00:00 MAC are fully functional — that's what you want. Note that they all have identical package and unit part numbers and even UPC — crazy!
Attached Images
    
__________________
G05 X5 x40i (04/2019 mfg, Canada) on S18A-19-11-540

Last edited by LexxM3; 03-11-2020 at 01:51 AM..
Appreciate 1
teefive150.50

      03-10-2020, 12:28 PM   #28
teefive
Lieutenant
151
Rep
448
Posts

Drives: G05 X5 40i
Join Date: Sep 2015
Location: NW AR

iTrader: (0)

Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by teefive View Post
Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by bichoo View Post
Quote:
Originally Posted by LexxM3 View Post
Well, my first try at this didn't go as smoothly as yours. Received the unit on Sat morning, D440-0047, everything looks right. Hood up, car locked, take the key far away, wait 15min. Install harness in the two spots (3pin near the front, 4 pin in the middle), tie wrap everything. Car on, engine off, the unit LED lights up and ... everything from then on went badly. Summary:
  • the D-SPORT app on iOS mostly wouldn't find the unit at all (just sits there scanning for BT devices, finding nothing); but when it did find it and switched to an intro splash screen, it then immediately crashed within 0.5-1 seconds; tried reboots, swipe aways, re-installs ... on 3 different iPhone models (6, 8, and XR) with 3 different iOS versions (12.4.3, 13.3, and 13.3.1)
  • started engine, car idled rough then settled down after a few seconds; but if you give it a little revs (even below 3000 rpm), wouldn't spin up, be very rough, or even stalled a few times
  • decided to go slow around the block; CEL blaring, continuous stalling, barely made it back to the garage
Obviously I immediately removed it; car went back to normal, but I now have "permanent" CEL "boost pressure too high" codes everywhere.

Discussed with Dinan, they assert it's a defective unit and we've arranged for my local distributor to get a replacement, should be in next weekend. That's good customer service, even on the weekend! But I sure hope it was a rare defect, was really looking forward to a simple gentle boost to stock. Wondering what warranty impact the CEL codes will have if there is an issue. Will report back after next weekend.
did you get a replacement yet from Dinan and try it out?
Yes, just resolved this weekend. I will find the time for the big/full story, but summary:

- don't buy without attention to source and date/time stamps on the unit (part number/UPC/model are NOT sufficient due to massive Dinan logistics screw up)

- when/if you receive the actually right ordered unit, it's easy and it appears to work :-)
How's the tune treating you?
Third unit was the charm. Once I received the right unit, it works great. I am still getting used to it and will do some app-level "dyno" runs (using PerfExpert app after careful/proper setup) in different modes and then with it out when the car is in for service, but I am pretty happy after a couple of days of engine self-calibration on Race mode with 93 octane fuel. It's not a massive increase, but feels good and stock-smooth. App works both on Android and modern iOS when it connects to a unit that actually works and has Bluetooth inside.

Thank you teefive, literally could not have done it without you!

Now for the PSA ... Dinan has some shit broken units out there in the supply chain; it's unbelievable that Dinan has allowed this, but believe it. If anyone wants to buy one of these, call your supplier and make sure of two things BEFORE allowing them to ship to you: a) the package and unit manufacture dates are both 2019 or later (not 2017) and b) the unit label has a proper Bluetooth MAC address (not all 00:00:00:00:00:00).

See pics below. The 2017 and 00:00 MAC are NON-FUNCTIONAL and there appear to be plenty of these on the shelves (the large distributor for my shop has now pulled all of these off their shelves as a result of my ordeal). The 2019 and non-00:00 MAC are fully functional — that's what you want. Note that they all have identical package and unit part numbers and even UPC — crazy!
Great to hear! I'm having the same experience as you ... an extra kick of power without any hiccups.
__________________
2020 G05 40i | ZMP | Carbon Black | Ivory
Appreciate 1
LexxM3959.00

      03-27-2020, 09:03 AM   #29
bichoo
Lieutenant
bichoo's Avatar
Canada
254
Rep
482
Posts

Drives: BMW X5 40i M-Sport
Join Date: Sep 2012
Location: Ottawa, Canada

iTrader: (0)

Quote:
Originally Posted by Stealthall View Post
Installed my DINAN and BMS intake. It's a nice amount of extra punch to tie me over until the tuners crack the Nov software upgrade.
Is this the intake you got: https://burgertuning.com/products/bm...bacc7284&_ss=r
__________________
2019 BMW X5 40i Phytonic Blue/Tartufo
2016 BMW X3 35i M-Sport, Dinantronics (sold)
2012 BMW X3 28i (sold)
Appreciate 0
      04-01-2020, 05:52 PM   #30
X54TH
Member
X54TH's Avatar
Canada
662
Rep
1,766
Posts

Drives: 2019 X5 40i M Sport
Join Date: Feb 2011
Location: GTA

iTrader: (0)

Garage List
Quote:
Originally Posted by bichoo View Post
Quote:
Originally Posted by Stealthall View Post
Installed my DINAN and BMS intake. It's a nice amount of extra punch to tie me over until the tuners crack the Nov software upgrade.
Is this the intake you got: https://burgertuning.com/products/bm...7284&_ss=r
Bichoo, you looking to do the same. Curious to know if the sound is enhanced.
__________________
2019 X5 Alpine White M-Sport
Software Version 11/2019.40
2018 M2 Alpine White
2017 230 Alpine white
Appreciate 0
      04-08-2020, 10:40 AM   #31
bichoo
Lieutenant
bichoo's Avatar
Canada
254
Rep
482
Posts

Drives: BMW X5 40i M-Sport
Join Date: Sep 2012
Location: Ottawa, Canada

iTrader: (0)

Quote:
Originally Posted by X54TH View Post
Bichoo, you looking to do the same. Curious to know if the sound is enhanced.
I'm thinking about it but my concern is perhaps needing to remove it for servicing, which is going to be a pain. From some videos I have seen, the sound is definitely enhanced.

I did order the Dinantronics, waiting for it to arrive
__________________
2019 BMW X5 40i Phytonic Blue/Tartufo
2016 BMW X3 35i M-Sport, Dinantronics (sold)
2012 BMW X3 28i (sold)
Appreciate 0
      04-08-2020, 12:20 PM   #32
X54TH
Member
X54TH's Avatar
Canada
662
Rep
1,766
Posts

Drives: 2019 X5 40i M Sport
Join Date: Feb 2011
Location: GTA

iTrader: (0)

Garage List
Blank

I've been thinking about Dinantronics. Had it on the F15 X5 and the M235. Didn't see the tune for the G05. I'll go back and have another look.
__________________
2019 X5 Alpine White M-Sport
Software Version 11/2019.40
2018 M2 Alpine White
2017 230 Alpine white
Appreciate 0
      04-08-2020, 06:32 PM   #33
LexxM3
Lieutenant Colonel
LexxM3's Avatar
Canada
959
Rep
1,619
Posts

Drives: E46M3, G05X5
Join Date: Apr 2019
Location: Waterloo, Canada

iTrader: (0)

Garage List
2019 X5  [0.00]
Quote:
Originally Posted by X54TH View Post
I've been thinking about Dinantronics. Had it on the F15 X5 and the M235. Didn't see the tune for the G05. I'll go back and have another look.
Read this thread. After Dinan finally delivered a non-broken unit, DINANtronics Sport is easy to install, inexpensive, and is working great. I now drive default SportPlus and RaceMode. Fuel consumption up a bit, but not serious.
__________________
G05 X5 x40i (04/2019 mfg, Canada) on S18A-19-11-540
Appreciate 0
      04-08-2020, 06:35 PM   #34
X54TH
Member
X54TH's Avatar
Canada
662
Rep
1,766
Posts

Drives: 2019 X5 40i M Sport
Join Date: Feb 2011
Location: GTA

iTrader: (0)

Garage List
Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by X54TH View Post
I've been thinking about Dinantronics. Had it on the F15 X5 and the M235. Didn't see the tune for the G05. I'll go back and have another look.
Read this thread. After Dinan finally delivered a non-broken unit, DINANtronics Sport is easy to install, inexpensive, and is working great. I now drive default SportPlus and RaceMode
Reminds of the F15. Did you order it through Dinan or the dealership? I got my previous tune from Budds and it was $400.
__________________
2019 X5 Alpine White M-Sport
Software Version 11/2019.40
2018 M2 Alpine White
2017 230 Alpine white
Appreciate 0
      04-08-2020, 07:10 PM   #35
LexxM3
Lieutenant Colonel
LexxM3's Avatar
Canada
959
Rep
1,619
Posts

Drives: E46M3, G05X5
Join Date: Apr 2019
Location: Waterloo, Canada

iTrader: (0)

Garage List
2019 X5  [0.00]
Quote:
Originally Posted by X54TH View Post
Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by X54TH View Post
I've been thinking about Dinantronics. Had it on the F15 X5 and the M235. Didn't see the tune for the G05. I'll go back and have another look.
Read this thread. After Dinan finally delivered a non-broken unit, DINANtronics Sport is easy to install, inexpensive, and is working great. I now drive default SportPlus and RaceMode
Reminds of the F15. Did you order it through Dinan or the dealership? I got my previous tune from Budds and it was $400.
DINANtronics Sport is not exactly a tune (at least not the way I think about a tune ie ECU parameters modification in software). It's a module that is plugged in between turbo boost sensors and the ECU and modifies the sensor signals in line to the ECU to ask for more (or less in Valet Mode) boost.

I got it here: https://www.parkautomotorsports.ca/products/d440-0047. This is a real-life tuning shop near me with online delivery. Great guys, stuck it out with me to solve the Dinan bad units problem. Mention my real name (which you know) and they will definitely remember me and make sure a bad/old Dinan unit doesn't slip through.
__________________
G05 X5 x40i (04/2019 mfg, Canada) on S18A-19-11-540
Appreciate 1
X54TH662.00

      04-08-2020, 07:12 PM   #36
X54TH
Member
X54TH's Avatar
Canada
662
Rep
1,766
Posts

Drives: 2019 X5 40i M Sport
Join Date: Feb 2011
Location: GTA

iTrader: (0)

Garage List
Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by X54TH View Post
Quote:
Originally Posted by LexxM3 View Post
Quote:
Originally Posted by X54TH View Post
I've been thinking about Dinantronics. Had it on the F15 X5 and the M235. Didn't see the tune for the G05. I'll go back and have another look.
Read this thread. After Dinan finally delivered a non-broken unit, DINANtronics Sport is easy to install, inexpensive, and is working great. I now drive default SportPlus and RaceMode
Reminds of the F15. Did you order it through Dinan or the dealership? I got my previous tune from Budds and it was $400.
DINANtronics Sport is not exactly a tune (at least not the way I think about a tune ie ECU parameters modification in software). It's a module that is plugged in between turbo boost sensors and the ECU and modifies the sensor signals in line to the ECU to ask for more (or less in Valet Mode) boost.

I got it here: https://www.parkautomotorsports.ca/products/d440-0047. This is a physical shop with online delivery near me. Great guys, stuck it out with me to solve the Dinan bad units problem. Mention my real name (which you know) and they will definitely remember me and make sure a bad/old Dinan unit doesn't slip through.
Perfect.
__________________
2019 X5 Alpine White M-Sport
Software Version 11/2019.40
2018 M2 Alpine White
2017 230 Alpine white
Appreciate 0
      04-09-2020, 07:40 PM   #37
bichoo
Lieutenant
bichoo's Avatar
Canada
254
Rep
482
Posts

Drives: BMW X5 40i M-Sport
Join Date: Sep 2012
Location: Ottawa, Canada

iTrader: (0)

Quote:
Originally Posted by X54TH View Post
Perfect.
I ordered from the same place as Lex mentioned, highly recommend. I'm waiting for it to arrive.
__________________
2019 BMW X5 40i Phytonic Blue/Tartufo
2016 BMW X3 35i M-Sport, Dinantronics (sold)
2012 BMW X3 28i (sold)
Appreciate 2
X54TH662.00
LexxM3959.00

      04-23-2020, 08:34 PM   #38
bichoo
Lieutenant
bichoo's Avatar
Canada
254
Rep
482
Posts

Drives: BMW X5 40i M-Sport
Join Date: Sep 2012
Location: Ottawa, Canada

iTrader: (0)

I just installed me tonight and took the beast out for a spin. A definite improvement! I can feel the extra pull right away, it "kicks" in right around 1500-2000rpm. I know that I will have to drive it more to allow the ecu to adapt and smooth out any jerkiness. This is based on my previous dinantronics. Very happy so far! I'll report back after driving it a bit more.
__________________
2019 BMW X5 40i Phytonic Blue/Tartufo
2016 BMW X3 35i M-Sport, Dinantronics (sold)
2012 BMW X3 28i (sold)
Appreciate 3
LexxM3959.00
teefive150.50
X54TH662.00

      04-23-2020, 09:53 PM   #39
LexxM3
Lieutenant Colonel
LexxM3's Avatar
Canada
959
Rep
1,619
Posts

Drives: E46M3, G05X5
Join Date: Apr 2019
Location: Waterloo, Canada

iTrader: (0)

Garage List
2019 X5  [0.00]
Quote:
Originally Posted by bichoo View Post
I just installed me tonight and took the beast out for a spin. A definite improvement! I can feel the extra pull right away, it "kicks" in right around 1500-2000rpm. I know that I will have to drive it more to allow the ecu to adapt and smooth out any jerkiness. This is based on my previous dinantronics. Very happy so far! I'll report back after driving it a bit more.
Race Mode?
__________________
G05 X5 x40i (04/2019 mfg, Canada) on S18A-19-11-540
Appreciate 0
      04-28-2020, 09:07 PM   #40
bichoo
Lieutenant
bichoo's Avatar
Canada
254
Rep
482
Posts

Drives: BMW X5 40i M-Sport
Join Date: Sep 2012
Location: Ottawa, Canada

iTrader: (0)

Quote:
Originally Posted by LexxM3 View Post
Race Mode?
I'm keeping it in Sport+ mode as Octane 93 is recommended and i'm only putting in 91.
After driving 100km or so, the ecu has adapted and it is definitely smoother. Comparing it to the dinantronics i had in my X3 F25, it is definitely smoother on the G05, albeit it was more noticeable on the F25.

I find that I only really feel the added pull if i push the car a bit during acceleration.
__________________
2019 BMW X5 40i Phytonic Blue/Tartufo
2016 BMW X3 35i M-Sport, Dinantronics (sold)
2012 BMW X3 28i (sold)
Appreciate 1
LexxM3959.00

Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:35 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST