BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      08-10-2021, 11:53 AM   #1
micmitch
Private
United_States
22
Rep
66
Posts

Drives: 2019 X5, 2018 Accord
Join Date: Jun 2019
Location: South Carolina

iTrader: (0)

Emergency Call System Malfunction

Hey all,

I have a July 2019 X5. This message popped up a couple of days ago and hasn't gone away. I rebooted the iDrive system, but there has been no change.

I assume I'll need to take it to the dealer, but I thought I'd check here first for any suggestions.

Thanks
Appreciate 0
      08-10-2021, 12:04 PM   #2
spike5150
Captain
377
Rep
951
Posts

Drives: 2020 X5 M50i
Join Date: Jun 2015
Location: Denver Area

iTrader: (0)

Quote:
Originally Posted by micmitch View Post
Hey all,

I have a July 2019 X5. This message popped up a couple of days ago and hasn't gone away. I rebooted the iDrive system, but there has been no change.

I assume I'll need to take it to the dealer, but I thought I'd check here first for any suggestions.

Thanks
Mine needed a replacement Telematics module when that happened. Eventually all cellular related functions quit working.
Appreciate 1
      08-15-2021, 08:27 PM   #3
jambo58
New Member
7
Rep
21
Posts

Drives: BMW X5 G05 xDrive40i
Join Date: May 2020
Location: Australia

iTrader: (0)

take into the dealer right away your TCM module has failed. there must have been a bad batch for the 2019 Models, this seems to be getting quite common
Appreciate 0
      08-17-2021, 10:30 AM   #4
Xeno
Major
Xeno's Avatar
275
Rep
1,352
Posts

Drives: 2019 X5 M Sport 5.0i
Join Date: Nov 2011
Location: USA

iTrader: (0)

There are previous accounts in this thread:

https://g05.bimmerpost.com/forums/sh...ight=emergency
__________________
2019 BMW X5 xDrive 50i M Sports: ZD8/ZLS/ZMP/ZP2/ZPK/ZPX/337/ZX7/2NH
2015 BMW X5 xDrive 50i/XL/CW/DA+/EP/LP/FVS retired; 2008 X5 4.8i; 2012 X5 5.0i retired, 2004 X4 4.4i retired
R360c + EL, V1G2 + V1Driver, Uniden R7
Appreciate 1
      09-23-2021, 04:19 AM   #5
zucchini
Registered
0
Rep
1
Posts

Drives: X5 40i
Join Date: Sep 2021
Location: China

iTrader: (0)

I have replaced my TCB module for the same issue, but my idrive system is now completely offline, any functions needed data connection is unavailale. SA told me they had done all they must to do, he asked me to contact the BMW。Does anyone have an idea what's going wrong?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:50 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST