BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      12-06-2018, 09:16 AM   #1
dptomlin48
New Member
4
Rep
10
Posts

Drives: 2013 BMW x1
Join Date: Apr 2015
Location: United States

iTrader: (0)

Bluetooth and heads up display problems

I picked my x5 50i up last week and I absolutely love it. I am having three Issues. My heads up display keeps resetting itself to a lower level than I have it set, often the playlist to music which is supposed to show in the heads up display won’t work. Not only that but when I hit the BC button on the turn signal that won’t change anything in the dash. When I restart the car then it works again, and my IPhone XS Max will connect for a minute then disconnect, then apple car play will connect then disconnect then sometimes the phone won’t connect st all. I have completely reset the idrive and it doesn’t help. I have updated my phone and it still has connection issues. Any idea or an idea of what to do.
Appreciate 0
      12-06-2018, 10:29 AM   #2
AndroidRobot
Brigadier General
AndroidRobot's Avatar
United_States
2033
Rep
4,546
Posts

Drives: 2019 X5 50i Carbon/Tartufo
Join Date: Apr 2018
Location: Texas

iTrader: (0)

Test another phone and see if the connection issues persist
__________________
2019 BMW X5 50i Carbon Black/Tartufo
G05 X5 50i Review
G01 X3 M40i/MKII Audi SQ5 Comparison
Appreciate 0
      12-06-2018, 05:06 PM   #3
mjchernis
Private
10
Rep
67
Posts

Drives: BMW X5
Join Date: Aug 2018
Location: New York

iTrader: (0)

Had two of these problems:


1) The HUD went away when I configured my driver profile and linked that profile to the key. May have also configured the driver recognition so not exactly sure what fixed it.

2) The iPhone problem went away when I disabled the Wi-Fi in the car and only used Bluetooth. Not sure if this is an option with CarPlay. Try disabling Wi-Fi in car or phone temporarily to see if that helps.

Good luck.
Appreciate 0
      12-06-2018, 05:55 PM   #4
JayPichardo
BMW Client Advisor
JayPichardo's Avatar
2897
Rep
2,446
Posts

Drives: 2020 M340i
Join Date: May 2017
Location: Tulley BMW Nashua, NH

iTrader: (0)

Garage List
2020 BMW M340i  [0.00]
Carplay needs wifi to work
__________________

Contact me for all your BMW needs in the New England area.
Appreciate 0
      12-06-2018, 06:19 PM   #5
mjchernis
Private
10
Rep
67
Posts

Drives: BMW X5
Join Date: Aug 2018
Location: New York

iTrader: (0)

Figured as much..but, might help isolate the problem with the phone. And, if OP can do without CarPlay the phone won't connect/disconnect and you can use other features.
Appreciate 0
      12-06-2018, 08:04 PM   #6
dptomlin48
New Member
4
Rep
10
Posts

Drives: 2013 BMW x1
Join Date: Apr 2015
Location: United States

iTrader: (0)

Quote:
Originally Posted by mjchernis View Post
Had two of these problems:


1) The HUD went away when I configured my driver profile and linked that profile to the key. May have also configured the driver recognition so not exactly sure what fixed it.

2) The iPhone problem went away when I disabled the Wi-Fi in the car and only used Bluetooth. Not sure if this is an option with CarPlay. Try disabling Wi-Fi in car or phone temporarily to see if that helps.

Good luck.
When I disabled apple car play everything has worked perfectly now. Thank you!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:27 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST