BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      10-15-2019, 02:38 PM   #1
mnewnam
First Lieutenant
168
Rep
350
Posts

Drives: '19 Mineral White X5 40i
Join Date: Feb 2014
Location: Houston, TX

iTrader: (0)

Exhaust smell at cold start

So, if I get in the car ('19 X5 40i) and start it when cold there's a whiff of exhaust while the engine warms up. If I run around to a few different stores I won't smell it at each of those starts from warm. However, the next cold start will do the same thing. It's the same smell you get if standing behind the vehicle when it starts. At first I thought maybe I was starting it before I closed my door but even with making sure it's closed before starting I still get it. If I remote start and wait, the smell has mostly dissipated by the time I get in.

I reached out to my SA to bring it in, but wondered if anyone else has experienced something like this. Thank you!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:41 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST