BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      07-19-2020, 09:55 PM   #45
VTENGR
Lieutenant Colonel
630
Rep
1,530
Posts

Drives: 2020 X5 M50i
Join Date: Aug 2018
Location: Atlanta

iTrader: (1)

Those of us with B&W sound - if you have the speakers match the ambient colors, it looks like the door speakers stay with the stock color and the tweeters on the doors will be white or stock colors, depending on which color configuration you choose in the iDrive menu. It would be great if we could crack the code for these so we can have them match or increase the color combos.
Appreciate 0
      07-20-2020, 06:45 PM   #46
hkleyman
Second Lieutenant
hkleyman's Avatar
United_States
89
Rep
271
Posts

Drives: 2019 BMW X5 50i M-Sport
Join Date: Aug 2019
Location: Saint Paul, MN

iTrader: (0)

Quote:
Originally Posted by OzJedi View Post
Just tried my hands on few more colors.

Thanks to this post https://g05.bimmerpost.com/forums/sh...php?p=26169693 for sharing color codes
Awesome. My favorite is green and blue (with both colors set to regular FF values to get rid of the mint green and sky blue and make them true.)
Attached Images
    
Appreciate 0
      07-20-2020, 09:18 PM   #47
OzJedi
Second Lieutenant
Australia
70
Rep
243
Posts

Drives: X5 2019 40i MSport Carb Black
Join Date: Apr 2019
Location: Sydney

iTrader: (0)

Quote:
Originally Posted by hkleyman View Post
Awesome. My favorite is green and blue (with both colors set to regular FF values to get rid of the mint green and sky blue and make them true.)
Nice!! Green looks great with regular FF values, I also like CYAN and Yellow.
Appreciate 0
      08-20-2020, 11:28 AM   #48
Pumxee
Private First Class
Pumxee's Avatar
Canada
51
Rep
170
Posts

Drives: BMW X6
Join Date: Jul 2020
Location: Calgary

iTrader: (0)

Anyone try and change the actual colour names in i-drive?
Appreciate 0
      08-20-2020, 11:31 AM   #49
Pumxee
Private First Class
Pumxee's Avatar
Canada
51
Rep
170
Posts

Drives: BMW X6
Join Date: Jul 2020
Location: Calgary

iTrader: (0)

How has the OP's original post only been appreciated 9 times? Come one guys let's give credit where due. Thanks OP!
Appreciate 0
      08-20-2020, 02:58 PM   #50
130FeetDeep
Lieutenant
178
Rep
410
Posts

Drives: BMW X5 M50i
Join Date: Nov 2019
Location: Northwest North Korea

iTrader: (0)

Quote:
Originally Posted by Pumxee View Post
How has the OP's original post only been appreciated 9 times? Come one guys let's give credit where due. Thanks OP!
Haha. Thank you!
Appreciate 0
      08-20-2020, 03:00 PM   #51
Pumxee
Private First Class
Pumxee's Avatar
Canada
51
Rep
170
Posts

Drives: BMW X6
Join Date: Jul 2020
Location: Calgary

iTrader: (0)

Quote:
Originally Posted by 130FeetDeep View Post
Haha. Thank you!
I just coded the red-blue combo into the bronze color space!

I still find it unbelievable the BMW has not enabled users to choose what color they want. I mean ford has been doing that since 2011.

I wonder wether bimmercode will create a standard mode option to allow for that.
Appreciate 0
      08-21-2020, 10:40 AM   #52
mnavis29
New Member
3
Rep
20
Posts

Drives: BMW 435xD
Join Date: Jan 2017
Location: Austria

iTrader: (0)

Anybody tried to access "360A LicLciColorLibrary" with Bimmercode 3.7 (10880) and iDrive FW 07/2020.35?

Getting the "no functions available" notification and am not even able to go into the particular file to change the HEX values.
Appreciate 0
      08-21-2020, 11:00 AM   #53
The J-Man
Captain
276
Rep
854
Posts

Drives: BMW
Join Date: Aug 2009
Location: Denver

iTrader: (0)

It appears there are 40+ colors already defined in the color library. It seems BMW may have put them there to open future colors? It would be helpful to figure out how the colors are mapped to the slots in the color profiles. That way, the BMW colors could just be used, but that may be more complicated, I'm not sure. I've also looked high and low for B&W settings and cannot find them in any module - speaking German would probably help, as they've probably named it something obscure. I find that leaving the speakers white is a good solution for now.
__________________
2020 X5 M50i Phytonic Blue/Black - PCD 10/21/2019
2015 i3 Rex Caparis White/Tera - Current
2016 550i M-Sport Alpine White/Ivory - Retired
2011 X5 35i BSM/Black - Retired
2011 335i Coupe Alpine White/Saddle - Retired (ED)
Appreciate 0
      08-21-2020, 02:38 PM   #54
hkleyman
Second Lieutenant
hkleyman's Avatar
United_States
89
Rep
271
Posts

Drives: 2019 BMW X5 50i M-Sport
Join Date: Aug 2019
Location: Saint Paul, MN

iTrader: (0)

Quote:
Originally Posted by The J-Man View Post
It appears there are 40+ colors already defined in the color library. It seems BMW may have put them there to open future colors? It would be helpful to figure out how the colors are mapped to the slots in the color profiles. That way, the BMW colors could just be used, but that may be more complicated, I'm not sure. I've also looked high and low for B&W settings and cannot find them in any module - speaking German would probably help, as they've probably named it something obscure. I find that leaving the speakers white is a good solution for now.
An FYI for everyone, it was discovered on the 3 series forum that if you code any colors to the full FF values, the two small ambient lights on the roof function module (by the sunroof switch) will not illuminate upon vehicle startup. The only way to resolve is changing the color and changing it back, adjusting brightness or unchecking / checking the enable ambient light option will not resolve.

It seems to be a bug with any full values, whereas any amount of mix does not exhibit this issue. I set my green, blue, and red all to their FF0000 / 00FF00 / 0000FF values and have this issue with all of them.

The gent that found this out was able to only change the mapping for the one layer that controls those wash ambient lamps to be slightly mixed while leaving the door / dash / floor strips as full values and it resolved the issue for him.
Appreciate 1
      08-25-2020, 08:19 AM   #55
garysmith21
Enlisted Member
United Kingdom
4
Rep
37
Posts

Drives: X5 xDrive45e M Sport (ordered)
Join Date: Dec 2018
Location: Edinburgh

iTrader: (0)

Quote:
Originally Posted by Pumxee View Post
Anyone try and change the actual colour names in i-drive?
This would be a very neat solution if anyone has managed to do it?
Appreciate 0
      08-25-2020, 08:23 AM   #56
Pumxee
Private First Class
Pumxee's Avatar
Canada
51
Rep
170
Posts

Drives: BMW X6
Join Date: Jul 2020
Location: Calgary

iTrader: (0)

Quote:
Originally Posted by garysmith21 View Post
Quote:
Originally Posted by Pumxee View Post
Anyone try and change the actual colour names in i-drive?
This would be a very neat solution if anyone has managed to do it?
I tried to snooze the settings but have no clue where this is and don't really want to experiment with it
__________________
Pum Performance Website Coming Soon!

BMW Parts and Accessories

https://pumperformance.com
Appreciate 0
      08-25-2020, 09:36 AM   #57
130FeetDeep
Lieutenant
178
Rep
410
Posts

Drives: BMW X5 M50i
Join Date: Nov 2019
Location: Northwest North Korea

iTrader: (0)

Quote:
Originally Posted by hkleyman View Post
An FYI for everyone, it was discovered on the 3 series forum that if you code any colors to the full FF values, the two small ambient lights on the roof function module (by the sunroof switch) will not illuminate upon vehicle startup. The only way to resolve is changing the color and changing it back, adjusting brightness or unchecking / checking the enable ambient light option will not resolve.

It seems to be a bug with any full values, whereas any amount of mix does not exhibit this issue. I set my green, blue, and red all to their FF0000 / 00FF00 / 0000FF values and have this issue with all of them.

The gent that found this out was able to only change the mapping for the one layer that controls those wash ambient lamps to be slightly mixed while leaving the door / dash / floor strips as full values and it resolved the issue for him.
Can you elaborate what you mean “Ambient lamps to be slightly mixed while leave the door / dash / floor strips as full values”. You also mention full versus mix. Can you elaborate on that?
Appreciate 0
      08-25-2020, 10:34 AM   #58
VTENGR
Lieutenant Colonel
630
Rep
1,530
Posts

Drives: 2020 X5 M50i
Join Date: Aug 2018
Location: Atlanta

iTrader: (1)

Quote:
Originally Posted by 130FeetDeep View Post
Can you elaborate what you mean “Ambient lamps to be slightly mixed while leave the door / dash / floor strips as full values”. You also mention full versus mix. Can you elaborate on that?
I think what he means is when you put in the hex FF0000 that's full red - 100%. If you do that it bugs out iDrive. However if you put in EE0000 that's so very close to red you will never tell the difference, but won't bug out iDrive.
Appreciate 1
      08-25-2020, 10:42 AM   #59
hkleyman
Second Lieutenant
hkleyman's Avatar
United_States
89
Rep
271
Posts

Drives: 2019 BMW X5 50i M-Sport
Join Date: Aug 2019
Location: Saint Paul, MN

iTrader: (0)

Quote:
Originally Posted by VTENGR View Post
Quote:
Originally Posted by 130FeetDeep View Post
Can you elaborate what you mean "Ambient lamps to be slightly mixed while leave the door / dash / floor strips as full values". You also mention full versus mix. Can you elaborate on that?
I think what he means is when you put in the hex FF0000 that's full red - 100%. If you do that it bugs out iDrive. However if you put in EE0000 that's so very close to red you will never tell the difference, but won't bug out iDrive.
Yep sorry, I'm bad at explaining. That's exactly the issue. For some reason when you tell the system 100% of any of the colors, so the red led is 100% and the green and blue are off for example, the two small ambient lights near the sunroof controls don't turn on after the car fully sleeps.
Appreciate 1
      08-25-2020, 10:43 AM   #60
biterror
Private First Class
Finland
51
Rep
135
Posts

Drives: X1 25d Xdrive, 530d Xdrive
Join Date: Aug 2020
Location: Random

iTrader: (0)

Quote:
Originally Posted by VTENGR View Post
I think what he means is when you put in the hex FF0000 that's full red - 100%. If you do that it bugs out iDrive. However if you put in EE0000 that's so very close to red you will never tell the difference, but won't bug out iDrive.
FE0000 is the next smaller value for red. EE0000 is much smaller already. :-)
Appreciate 0
      08-25-2020, 01:10 PM   #61
VTENGR
Lieutenant Colonel
630
Rep
1,530
Posts

Drives: 2020 X5 M50i
Join Date: Aug 2018
Location: Atlanta

iTrader: (1)

Quote:
Originally Posted by biterror View Post
FE0000 is the next smaller value for red. EE0000 is much smaller already. :-)
Yes, obviously. I was just using EE as an example. I'm guessing anything with the RED value above 200 will turn out red on the small LED strips we have (maybe even lower). Below that you're getting into the maroon/brick color territory.
Appreciate 0
      08-25-2020, 03:25 PM   #62
130FeetDeep
Lieutenant
178
Rep
410
Posts

Drives: BMW X5 M50i
Join Date: Nov 2019
Location: Northwest North Korea

iTrader: (0)

Quote:
Originally Posted by hkleyman View Post
Yep sorry, I'm bad at explaining. That's exactly the issue. For some reason when you tell the system 100% of any of the colors, so the red led is 100% and the green and blue are off for example, the two small ambient lights near the sunroof controls don't turn on after the car fully sleeps.
So going FE instead of FF will solve the overhead LED light issue? FF0000 correlates to 255 0 0 RGB. FE0000 correlates to 254 0 0 RGB. Honestly, the difference is not going to be detectable by the eye. Can we verify the FE0000 / 254 0 0 RGB will make the LED overhead splash lights work?

Once we verify, then I will update the DIY. I do notice that the other colors stock are using FE (254 RGB), so it appears you guys are spot on.

Last edited by 130FeetDeep; 08-25-2020 at 03:31 PM..
Appreciate 0
      08-25-2020, 03:34 PM   #63
hkleyman
Second Lieutenant
hkleyman's Avatar
United_States
89
Rep
271
Posts

Drives: 2019 BMW X5 50i M-Sport
Join Date: Aug 2019
Location: Saint Paul, MN

iTrader: (0)

Quote:
Originally Posted by 130FeetDeep View Post
Quote:
Originally Posted by hkleyman View Post
Yep sorry, I'm bad at explaining. That's exactly the issue. For some reason when you tell the system 100% of any of the colors, so the red led is 100% and the green and blue are off for example, the two small ambient lights near the sunroof controls don't turn on after the car fully sleeps.
So going FE instead of FF will solve the overhead LED light issue? FF0000 correlates to 255 0 0 RGB. FE0000 correlates to 254 0 0 RGB. Honestly, the difference is not going to be detectable by the eye. Can we verify the FE0000 / 254 0 0 RGB will make the LED overhead splash lights work?

Once we verify, then I will update the DIY. I do notice that the other colors stock are using FE (254 RGB), so it appears you guys are spot on.
I have been meaning to correct in my vehicle and test but haven't gotten to it. I'll update the thread as soon as I confirm.
Appreciate 0
      08-25-2020, 04:20 PM   #64
130FeetDeep
Lieutenant
178
Rep
410
Posts

Drives: BMW X5 M50i
Join Date: Nov 2019
Location: Northwest North Korea

iTrader: (0)

Quote:
Originally Posted by hkleyman View Post
I have been meaning to correct in my vehicle and test but haven't gotten to it. I'll update the thread as soon as I confirm.
If you can’t, then I will tonight. Do we know if the vehicle has to be just shut off to trigger the glitch? Does the DME have to go to sleep?

Honestly, looking at the other FE values / RGB 254, I am pretty confident that resolves this immediately. They must worry 255 will affect the life of the LED so explicitly choose 254.
Appreciate 0
      08-25-2020, 05:24 PM   #65
hkleyman
Second Lieutenant
hkleyman's Avatar
United_States
89
Rep
271
Posts

Drives: 2019 BMW X5 50i M-Sport
Join Date: Aug 2019
Location: Saint Paul, MN

iTrader: (0)

Quote:
Originally Posted by 130FeetDeep View Post
Quote:
Originally Posted by hkleyman View Post
I have been meaning to correct in my vehicle and test but haven't gotten to it. I'll update the thread as soon as I confirm.
If you can’t, then I will tonight. Do we know if the vehicle has to be just shut off to trigger the glitch? Does the DME have to go to sleep?

Honestly, looking at the other FE values / RGB 254, I am pretty confident that resolves this immediately. They must worry 255 will affect the life of the LED so explicitly choose 254.
The vehicle does have to fully sleep. It doesn't seem dependent on engine start (DME) but I assume BDC needs to sleep for it to happen.
Appreciate 0
      08-25-2020, 05:26 PM   #66
130FeetDeep
Lieutenant
178
Rep
410
Posts

Drives: BMW X5 M50i
Join Date: Nov 2019
Location: Northwest North Korea

iTrader: (0)

Quote:
Originally Posted by hkleyman View Post
The vehicle does have to fully sleep. It doesn't seem dependent on engine start (DME) but I assume BDC needs to sleep for it to happen.
Perfect. Good teamwork to move this project forward. I will make the change to FE0000 / RGB 254/0/0 tonight and report back.
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:03 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST