BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      08-03-2020, 10:25 PM   #1
OzJedi
Second Lieutenant
Australia
70
Rep
243
Posts

Drives: X5 2019 40i MSport Carb Black
Join Date: Apr 2019
Location: Sydney

iTrader: (0)

Remote 3D view doesn't show surroundings?

I noticed that my remote 3d view has stopped working after recent OTA upgrade. There is no error as such and all the steps in Refresh View are completed successfully but there seems to be an issue with rendering the surroundings. Car is shown in grey area without any surroundings.

Anyone else faced this issue and managed to resolve it?
Appreciate 0
      08-03-2020, 11:23 PM   #2
eagle_bmw
First Lieutenant
United_States
159
Rep
397
Posts

Drives: 2019 BMW X5 40i
Join Date: May 2019
Location: USA

iTrader: (0)

Quote:
Originally Posted by OzJedi View Post
I noticed that my remote 3d view has stopped working after recent OTA upgrade. There is no error as such and all the steps in Refresh View are completed successfully but there seems to be an issue with rendering the surroundings. Car is shown in grey area without any surroundings.

Anyone else faced this issue and managed to resolve it?
This happened to mine once or twice. It seems a camera or two failed to work so those sides will have blacked out rendering. You can verify if we had the same issue by going to Gallery, choose the date when you took the 3D view and click on the address (top). Normally there should be 4 wide angle photos. In my case only 2 cameras were able to capture images. See photos when it worked and not.
Attached Images
  
__________________
2019 X5 40i M-Sport, 07/2020.25
Appreciate 1
OzJedi70.00

      08-04-2020, 07:44 AM   #3
Bancroft
Private
45
Rep
78
Posts

Drives: BMW X5 45e
Join Date: Sep 2019
Location: Czech Republic

iTrader: (0)

How do you guys get this remote view in your phone? Is it part of the Connected app or do I need to buy something extra?
Appreciate 0
      08-04-2020, 08:20 AM   #4
Auricom
Colonel
Auricom's Avatar
United_States
1589
Rep
2,128
Posts

Drives: 2020 X5 xDrive40i M Sport
Join Date: Jan 2012
Location: DMV

iTrader: (0)

Quote:
Originally Posted by Bancroft View Post
How do you guys get this remote view in your phone? Is it part of the Connected app or do I need to buy something extra?
BMW ConnectedDrive App

Name:  2019-12-13 10.52.21.jpg
Views: 1554
Size:  78.1 KB
__________________
Current BMWs - '20 X5 xDrive40i M Sport, '20 BMW M550i | Past BMWs - '03 540iT M Sport, '06 E53 4.8is, '11 E70 M Sport LCI

Appreciate 0
      08-04-2020, 08:55 AM   #5
IftiBashir
Private First Class
29
Rep
113
Posts

Drives: 2019 X5 MSport 40i
Join Date: Jul 2020
Location: UK

iTrader: (0)

Quote:
Originally Posted by eagle_bmw View Post
This happened to mine once or twice. It seems a camera or two failed to work so those sides will have blacked out rendering. You can verify if we had the same issue by going to Gallery, choose the date when you took the 3D view and click on the address (top). Normally there should be 4 wide angle photos. In my case only 2 cameras were able to capture images. See photos when it worked and not.
How did you get the view from each individual camera??
Mine stitches them together to give me a full 360 view around the car......didnt see an option for individual camera images.....
Appreciate 0
      08-04-2020, 09:13 AM   #6
Auricom
Colonel
Auricom's Avatar
United_States
1589
Rep
2,128
Posts

Drives: 2020 X5 xDrive40i M Sport
Join Date: Jan 2012
Location: DMV

iTrader: (0)

Quote:
Originally Posted by IftiBashir View Post
How did you get the view from each individual camera??
Mine stitches them together to give me a full 360 view around the car......didnt see an option for individual camera images.....

Launch App > Tap Remote 3D View > Tap on the Date/Address shown in the latest view


1. Tap Remote 3D View

Name:  2019-12-13 10.52.21.jpg
Views: 1527
Size:  84.3 KB


2A. Tap on Date/Address shown in the latest view

Name:  2019-12-13 21.06.3A6.jpg
Views: 1464
Size:  88.9 KB


2B. View Details

Name:  IMG_5267.jpg
Views: 1495
Size:  52.9 KB


2C. Tap any of the Left/Right/Front/Back views to see the actual image captured.

Name:  IMG_5573.jpg
Views: 1486
Size:  74.3 KB


Tapping Gallery shows you a history of all your previous and successful Remote 3D Views captured.

Name:  2019-12-13 21.06.36.jpg
Views: 1457
Size:  85.9 KB


In Gallery View
  • Tapping View Details in Gallery View shows you 2B View Details of the Active View captured in the earlier screenshot.
  • Tapping any of the previous Remote 3D saved views will refresh and show you the images and location captured for that date.
  • Swipe left to delete an individual saved views from the app.

Name:  IMG_5268.jpg
Views: 1494
Size:  82.8 KB
__________________
Current BMWs - '20 X5 xDrive40i M Sport, '20 BMW M550i | Past BMWs - '03 540iT M Sport, '06 E53 4.8is, '11 E70 M Sport LCI


Last edited by Auricom; 08-04-2020 at 09:17 PM..
Appreciate 6
      08-04-2020, 09:31 AM   #7
IftiBashir
Private First Class
29
Rep
113
Posts

Drives: 2019 X5 MSport 40i
Join Date: Jul 2020
Location: UK

iTrader: (0)

Awesome thanks dude!!
Appreciate 0
      08-04-2020, 08:49 PM   #8
TestnDoc
Private
41
Rep
87
Posts

Drives: 2008 BMW M3
Join Date: Mar 2008
Location: Florida

iTrader: (0)

Cool stuff. Didn’t know about see individual camera pics!
__________________
20 BMW X5 M50i
19 BMW 850 (wifey)
18 S560
20 RR SVR (wifey)
Appreciate 0
      08-05-2020, 03:44 AM   #9
OzJedi
Second Lieutenant
Australia
70
Rep
243
Posts

Drives: X5 2019 40i MSport Carb Black
Join Date: Apr 2019
Location: Sydney

iTrader: (0)

Quote:
Originally Posted by eagle_bmw View Post
Quote:
Originally Posted by OzJedi View Post
I noticed that my remote 3d view has stopped working after recent OTA upgrade. There is no error as such and all the steps in Refresh View are completed successfully but there seems to be an issue with rendering the surroundings. Car is shown in grey area without any surroundings.

Anyone else faced this issue and managed to resolve it?
This happened to mine once or twice. It seems a camera or two failed to work so those sides will have blacked out rendering. You can verify if we had the same issue by going to Gallery, choose the date when you took the 3D view and click on the address (top). Normally there should be 4 wide angle photos. In my case only 2 cameras were able to capture images. See photos when it worked and not.
Interesting! I just see blank surroundings in these images. Even the old one which were displayed correctly now appear with blank surrounding.
I believe this is app issue rather than car issue. Possibly due to iOS 14 beta I am using.
Attached Images
  
Appreciate 0
      08-05-2020, 04:38 AM   #10
Auricom
Colonel
Auricom's Avatar
United_States
1589
Rep
2,128
Posts

Drives: 2020 X5 xDrive40i M Sport
Join Date: Jan 2012
Location: DMV

iTrader: (0)

Quote:
Originally Posted by OzJedi View Post
Quote:
Originally Posted by eagle_bmw View Post
Quote:
Originally Posted by OzJedi View Post
I noticed that my remote 3d view has stopped working after recent OTA upgrade. There is no error as such and all the steps in Refresh View are completed successfully but there seems to be an issue with rendering the surroundings. Car is shown in grey area without any surroundings.

Anyone else faced this issue and managed to resolve it?
This happened to mine once or twice. It seems a camera or two failed to work so those sides will have blacked out rendering. You can verify if we had the same issue by going to Gallery, choose the date when you took the 3D view and click on the address (top). Normally there should be 4 wide angle photos. In my case only 2 cameras were able to capture images. See photos when it worked and not.
Interesting! I just see blank surroundings in these images. Even the old one which were displayed correctly now appear with blank surrounding.
I believe this is app issue rather than car issue. Possibly due to iOS 14 beta I am using.
If you're using Beta 2 or earlier, it's due to AVFoundation not available. Specifically, AVAssetDownloadTask – session used to download HTTP Live Streaming assets.

Without AVFoundation, no assets can be captured or displayed

Release note issue for Beta 2 and earlier:
AVAssetDownloadTask options, AVAssetDownloadTaskMinimumRequiredPresentationSize Key, and AVAssetDownloadTaskAllowHighDynamicRangeKey are currently unavailable.

BMW ConnectedDrive uses AVFoundation:
AVFoundation Capture subsystem provides a common high-level architecture for video, photo, and audio capture services in iOS and macOS. Use this system if you want to:

Build a custom camera UI to integrate shooting photos or videos into your app's user experience.

Produce different results than the system camera UI, such as RAW format photos, depth maps, or videos with custom timed metadata.

Get live access to pixel or audio data streaming directly from a capture device.


TLDR; Upgrade to Beta 3 should fix it

Resolved in iOS & iPadOS 14 beta 3

AVAssetDownloadTask options, AVAssetDownloadTaskMinimumRequiredPresentationSize Key, and AVAssetDownloadTaskAllowHighDynamicRangeKey are now available.
__________________
Current BMWs - '20 X5 xDrive40i M Sport, '20 BMW M550i | Past BMWs - '03 540iT M Sport, '06 E53 4.8is, '11 E70 M Sport LCI

Appreciate 2
OzJedi70.00
Cooltones215.00

      08-05-2020, 05:43 AM   #11
OzJedi
Second Lieutenant
Australia
70
Rep
243
Posts

Drives: X5 2019 40i MSport Carb Black
Join Date: Apr 2019
Location: Sydney

iTrader: (0)

Quote:
Originally Posted by Auricom View Post
If you're using Beta 2 or earlier, it's due to AVFoundation not available. Specifically, AVAssetDownloadTask – session used to download HTTP Live Streaming assets.

Without AVFoundation, no assets can be captured or displayed

Release note issue for Beta 2 and earlier:
AVAssetDownloadTask options, AVAssetDownloadTaskMinimumRequiredPresentationSize Key, and AVAssetDownloadTaskAllowHighDynamicRangeKey are currently unavailable.

BMW ConnectedDrive uses AVFoundation:
AVFoundation Capture subsystem provides a common high-level architecture for video, photo, and audio capture services in iOS and macOS. Use this system if you want to:

Build a custom camera UI to integrate shooting photos or videos into your app's user experience.

Produce different results than the system camera UI, such as RAW format photos, depth maps, or videos with custom timed metadata.

Get live access to pixel or audio data streaming directly from a capture device.


TLDR; Upgrade to Beta 3 should fix it

Resolved in iOS & iPadOS 14 beta 3

AVAssetDownloadTask options, AVAssetDownloadTaskMinimumRequiredPresentationSize Key, and AVAssetDownloadTaskAllowHighDynamicRangeKey are now available.
Thank!!!
Appreciate 0
      08-05-2020, 06:50 AM   #12
Bancroft
Private
45
Rep
78
Posts

Drives: BMW X5 45e
Join Date: Sep 2019
Location: Czech Republic

iTrader: (0)

Quote:
Originally Posted by Auricom View Post
BMW ConnectedDrive App

Attachment 2380783
I don't see the 3D View button in my app. Why is that? I have the 360 view in my car only.
Appreciate 0
      08-05-2020, 07:13 AM   #13
MystroX5
Brigadier General
MystroX5's Avatar
3291
Rep
3,172
Posts

Drives: 2020 X7 M50i 2019 M2 Comp
Join Date: Dec 2018
Location: Central Pa.

iTrader: (0)

I use this feature all the time on vacation with my last X5. The split camera views are very useful.
I monitored my vehicle a few times a day while at the Grand Floridian in Feb. We even got clever and took some road trip pics using just the front camera view angle.





Last edited by MystroX5; 08-05-2020 at 07:19 AM..
Appreciate 0
      08-10-2020, 10:27 PM   #14
OzJedi
Second Lieutenant
Australia
70
Rep
243
Posts

Drives: X5 2019 40i MSport Carb Black
Join Date: Apr 2019
Location: Sydney

iTrader: (0)

Quote:
Originally Posted by Bancroft View Post
I don't see the 3D View button in my app. Why is that? I have the 360 view in my car only.
Did you enable it in iDrive? You need to enable it in iDrive

Under iDrive settings
Car
Settings
General Settings
Data Privacy
Configure services or Select services individually
if applicable BMW ConnectedDrive
Remote 3D View

You also need to enable Data transfer for this to work under
Car
Settings
General Settings
Data privacy
Select the desired setting
Appreciate 0
      08-10-2020, 10:29 PM   #15
OzJedi
Second Lieutenant
Australia
70
Rep
243
Posts

Drives: X5 2019 40i MSport Carb Black
Join Date: Apr 2019
Location: Sydney

iTrader: (0)

Quote:
Originally Posted by Auricom View Post
If you're using Beta 2 or earlier, it's due to AVFoundation not available. Specifically, AVAssetDownloadTask – session used to download HTTP Live Streaming assets.

Without AVFoundation, no assets can be captured or displayed

Release note issue for Beta 2 and earlier:
AVAssetDownloadTask options, AVAssetDownloadTaskMinimumRequiredPresentationSize Key, and AVAssetDownloadTaskAllowHighDynamicRangeKey are currently unavailable.

BMW ConnectedDrive uses AVFoundation:
AVFoundation Capture subsystem provides a common high-level architecture for video, photo, and audio capture services in iOS and macOS. Use this system if you want to:

Build a custom camera UI to integrate shooting photos or videos into your app's user experience.

Produce different results than the system camera UI, such as RAW format photos, depth maps, or videos with custom timed metadata.

Get live access to pixel or audio data streaming directly from a capture device.


TLDR; Upgrade to Beta 3 should fix it

Resolved in iOS & iPadOS 14 beta 3

AVAssetDownloadTask options, AVAssetDownloadTaskMinimumRequiredPresentationSize Key, and AVAssetDownloadTaskAllowHighDynamicRangeKey are now available.
I recently upgraded to beta 4 but still same issue so it could be something else.
Appreciate 0
      08-10-2020, 11:43 PM   #16
timmahh
ghey
timmahh's Avatar
United_States
246
Rep
1,737
Posts

Drives: Viertürigen Fahrzeugs
Join Date: Oct 2010
Location: Southern California

iTrader: (1)

Quote:
Originally Posted by OzJedi View Post
Quote:
Originally Posted by Auricom View Post
If you're using Beta 2 or earlier, it's due to AVFoundation not available. Specifically, AVAssetDownloadTask – session used to download HTTP Live Streaming assets.

Without AVFoundation, no assets can be captured or displayed

Release note issue for Beta 2 and earlier:
AVAssetDownloadTask options, AVAssetDownloadTaskMinimumRequiredPresentationSize Key, and AVAssetDownloadTaskAllowHighDynamicRangeKey are currently unavailable.

BMW ConnectedDrive uses AVFoundation:
AVFoundation Capture subsystem provides a common high-level architecture for video, photo, and audio capture services in iOS and macOS. Use this system if you want to:

Build a custom camera UI to integrate shooting photos or videos into your app's user experience.

Produce different results than the system camera UI, such as RAW format photos, depth maps, or videos with custom timed metadata.

Get live access to pixel or audio data streaming directly from a capture device.


TLDR; Upgrade to Beta 3 should fix it

Resolved in iOS & iPadOS 14 beta 3

AVAssetDownloadTask options, AVAssetDownloadTaskMinimumRequiredPresentationSize Key, and AVAssetDownloadTaskAllowHighDynamicRangeKey are now available.
I recently upgraded to beta 4 but still same issue so it could be something else.
It's iOS 14, mine worked fine before it. Running latest beta it still doesn't render properly.
__________________
20 G05 > 17 G30> 14 F30 > 08 E90
Appreciate 0
      08-10-2020, 11:56 PM   #17
dsm4
New Member
United_States
0
Rep
6
Posts

Drives: M4/G05/E93
Join Date: Mar 2016
Location: Wilton Ca

iTrader: (0)

Privacy error

I have tried to select all the different privacy setting, I still get the error when I try to access the 3d view.
Appreciate 0
      08-11-2020, 01:11 AM   #18
marcosg
Private
Australia
18
Rep
85
Posts

Drives: G05 X5 M50D
Join Date: Sep 2012
Location: Sydney - Australia

iTrader: (0)

Quote:
Originally Posted by OzJedi View Post
I noticed that my remote 3d view has stopped working after recent OTA upgrade. There is no error as such and all the steps in Refresh View are completed successfully but there seems to be an issue with rendering the surroundings. Car is shown in grey area without any surroundings.

Anyone else faced this issue and managed to resolve it?
I have the same problem. This is what I get...

I am using iOS ver 14.0 (18A5342e). Not sure which Beta version is this. But I am on the latest iOS version.
Attached Images
 
Appreciate 0
      08-11-2020, 04:06 AM   #19
OzJedi
Second Lieutenant
Australia
70
Rep
243
Posts

Drives: X5 2019 40i MSport Carb Black
Join Date: Apr 2019
Location: Sydney

iTrader: (0)

Quote:
Originally Posted by marcosg View Post
Quote:
Originally Posted by OzJedi View Post
I noticed that my remote 3d view has stopped working after recent OTA upgrade. There is no error as such and all the steps in Refresh View are completed successfully but there seems to be an issue with rendering the surroundings. Car is shown in grey area without any surroundings.

Anyone else faced this issue and managed to resolve it?
I have the same problem. This is what I get...

I am using iOS ver 14.0 (18A5342e). Not sure which Beta version is this. But I am on the latest iOS version.
I am on same version, that's Beta4
Appreciate 0
      08-11-2020, 05:53 AM   #20
IftiBashir
Private First Class
29
Rep
113
Posts

Drives: 2019 X5 MSport 40i
Join Date: Jul 2020
Location: UK

iTrader: (0)

Was working fine - no issues.
Then all of a sudden it stopped working - no updates or changes at all.
Seems a very hit and miss service, which is a shame as when it works its great!
Appreciate 0
      08-11-2020, 06:32 AM   #21
Addbuyer
Second Lieutenant
Addbuyer's Avatar
79
Rep
207
Posts

Drives: M50i
Join Date: May 2020
Location: U.K.

iTrader: (0)

BMW Connected Drive have failed to help get the app working, let alone the 3D view. Terrible
Appreciate 0
      08-11-2020, 08:41 AM   #22
Auricom
Colonel
Auricom's Avatar
United_States
1589
Rep
2,128
Posts

Drives: 2020 X5 xDrive40i M Sport
Join Date: Jan 2012
Location: DMV

iTrader: (0)

If you're not running iOS Beta, it's something else that's causing the issue - either the service is down or connection issue.

If you're running iOS Beta, I wouldn't expect BMW Connected to be able to assist or troubleshoot app issues - features in apps won't necessarily work given a lot of the changes in iOS 14 Beta. My rule for Beta, either install it on a spare phone and never install Beta on your personal phone where you need everything to work.
__________________
Current BMWs - '20 X5 xDrive40i M Sport, '20 BMW M550i | Past BMWs - '03 540iT M Sport, '06 E53 4.8is, '11 E70 M Sport LCI

Appreciate 1
OzJedi70.00

Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:40 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST