BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      09-12-2020, 08:42 PM   #1
RJJJ
Private First Class
16
Rep
181
Posts

Drives: 2020 BMW X6 M50i
Join Date: Aug 2019
Location: NJ

iTrader: (0)

Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors no longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Attached Images
  
Appreciate 0
      09-12-2020, 09:14 PM   #2
hkleyman
Second Lieutenant
hkleyman's Avatar
United_States
89
Rep
271
Posts

Drives: 2019 BMW X5 50i M-Sport
Join Date: Aug 2019
Location: Saint Paul, MN

iTrader: (0)

Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors on longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Have you tried rebooting iDrive by holding the volume button in until the head unit reboots? Can take 45+ seconds to turn off and then it will reboot.
Appreciate 0
      09-12-2020, 09:14 PM   #3
doctorttt
First Lieutenant
United_States
101
Rep
331
Posts

Drives: 2020 G06
Join Date: Jun 2019
Location: New York

iTrader: (0)

RJJJ, you seem to have some bad luck with this vehicle. How long are you planning to keep it, may I ask? Do you live in NJ or NYC?

Sorry that I'm not being helpful but I'm sure someone will respond with a potential solution.
Appreciate 0
      09-12-2020, 09:44 PM   #4
RJJJ
Private First Class
16
Rep
181
Posts

Drives: 2020 BMW X6 M50i
Join Date: Aug 2019
Location: NJ

iTrader: (0)

Quote:
Originally Posted by hkleyman View Post
Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors on longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Have you tried rebooting iDrive by holding the volume button in until the head unit reboots? Can take 45+ seconds to turn off and then it will reboot.
Yes I did, but the problem persists...
Appreciate 0
      09-12-2020, 09:46 PM   #5
hkleyman
Second Lieutenant
hkleyman's Avatar
United_States
89
Rep
271
Posts

Drives: 2019 BMW X5 50i M-Sport
Join Date: Aug 2019
Location: Saint Paul, MN

iTrader: (0)

Quote:
Originally Posted by RJJJ View Post
Quote:
Originally Posted by hkleyman View Post
Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors on longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Have you tried rebooting iDrive by holding the volume button in until the head unit reboots? Can take 45+ seconds to turn off and then it will reboot.
Yes I did, but the problem persists...
It may disappear after the vehicle deep sleeps overnight but it may need ISTA to take a look!
Appreciate 0
      09-12-2020, 09:47 PM   #6
RJJJ
Private First Class
16
Rep
181
Posts

Drives: 2020 BMW X6 M50i
Join Date: Aug 2019
Location: NJ

iTrader: (0)

Quote:
Originally Posted by doctorttt View Post
RJJJ, you seem to have some bad luck with this vehicle. How long are you planning to keep it, may I ask? Do you live in NJ or NYC?

Sorry that I'm not being helpful but I'm sure someone will respond with a potential solution.
Really unlucky.... I live in NJ probably going to trade in this car after 3-5 years
Appreciate 0
      09-13-2020, 11:12 AM   #7
doctorttt
First Lieutenant
United_States
101
Rep
331
Posts

Drives: 2020 G06
Join Date: Jun 2019
Location: New York

iTrader: (0)

Quote:
Originally Posted by RJJJ View Post
Quote:
Originally Posted by doctorttt View Post
RJJJ, you seem to have some bad luck with this vehicle. How long are you planning to keep it, may I ask? Do you live in NJ or NYC?

Sorry that I'm not being helpful but I'm sure someone will respond with a potential solution.
Really unlucky.... I live in NJ probably going to trade in this car after 3-5 years
I feel ya. Car is just a tool/appliance. It comes and goes. I have had a number of bad lucks in life. Just enjoy.
Appreciate 0
      09-13-2020, 02:21 PM   #8
claykin
Brigadier General
United_States
598
Rep
3,412
Posts

Drives: various BMW
Join Date: Nov 2009
Location: Florida

iTrader: (0)

Quote:
Originally Posted by RJJJ View Post
Quote:
Originally Posted by doctorttt View Post
RJJJ, you seem to have some bad luck with this vehicle. How long are you planning to keep it, may I ask? Do you live in NJ or NYC?

Sorry that I'm not being helpful but I'm sure someone will respond with a potential solution.
Really unlucky.... I live in NJ probably going to trade in this car after 3-5 years
If you're having lots of issues, I suggest getting rid of it just prior to factory warranty ending. FWIW
__________________
2017 540i | 2019 X3 | 2019 540i MSport
Appreciate 0
      09-13-2020, 05:15 PM   #9
Osheatwo
Private
United_States
42
Rep
95
Posts

Drives: BMW 540i
Join Date: May 2018
Location: Atlanta

iTrader: (0)

Garage List
2019 BMW X5 M50i  [0.00]
2019 BMW 330i  [0.00]
2017 BMW 540i  [0.00]
Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors no longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Assuming the weather was good when this happen? Asking because I have seen this happen sometime when driving in severe rain.
Appreciate 0
      09-13-2020, 05:28 PM   #10
X54TH
Member
X54TH's Avatar
Canada
676
Rep
1,807
Posts

Drives: 2019 X5 40i M Sport
Join Date: Feb 2011
Location: GTA

iTrader: (0)

Garage List
Quote:
Originally Posted by Osheatwo View Post
Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors no longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Assuming the weather was good when this happen? Asking because I have seen this happen sometime when driving in severe rain.
I was in severe rain today and had the warning come up. Once the weather settled down everything returned to normal.
__________________
2019 X5 Alpine White M-Sport
Software Version 11/2019.70
2018 M2 Alpine White
2017 230 Alpine white
Appreciate 0
      09-13-2020, 06:48 PM   #11
James_G0530d
Lieutenant
Australia
230
Rep
534
Posts

Drives: 2019 X5 G05 30d M Sport A/Grey
Join Date: Sep 2019
Location: Melbourne, Australia

iTrader: (0)

Yes, I had this happen on my first (2018) G05.

This is a common occurrence in very poor weather, and is caused by the cars safety camera being obstructed by water or dirt, at least that is what the dealer told me when I took it in to get checked out.

It is yet to happen on my 2019 G05, so maybe they changed or updated something with the later model car.

I also wash my car weekly and keep it very clean.Try cleaning ALL your vehicle cameras, including the side (mirror) and rear cameras. You would be surprised to the extent these are integrated into the safety systems of the car.
Appreciate 0
      09-13-2020, 08:44 PM   #12
RJJJ
Private First Class
16
Rep
181
Posts

Drives: 2020 BMW X6 M50i
Join Date: Aug 2019
Location: NJ

iTrader: (0)

Quote:
Originally Posted by Osheatwo View Post
Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors no longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Assuming the weather was good when this happen? Asking because I have seen this happen sometime when driving in severe rain.
The weather was was good sunny....
Appreciate 0
      09-13-2020, 08:46 PM   #13
RJJJ
Private First Class
16
Rep
181
Posts

Drives: 2020 BMW X6 M50i
Join Date: Aug 2019
Location: NJ

iTrader: (0)

Quote:
Originally Posted by James_G0530d View Post
Yes, I had this happen on my first (2018) G05.

This is a common occurrence in very poor weather, and is caused by the cars safety camera being obstructed by water or dirt, at least that is what the dealer told me when I took it in to get checked out.

It is yet to happen on my 2019 G05, so maybe they changed or updated something with the later model car.

I also wash my car weekly and keep it very clean.Try cleaning ALL your vehicle cameras, including the side (mirror) and rear cameras. You would be surprised to the extent these are integrated into the safety systems of the car.
I have cleaned all the cameras, but the problem persists... I will go to see the dealer tomorrow
Appreciate 0
      09-13-2020, 09:03 PM   #14
m3_08
Private First Class
50
Rep
161
Posts

Drives: 2021x545e, e63swagon
Join Date: May 2015
Location: ATL

iTrader: (0)

Besides malfunction I know two reasons it may happened:
1. Storm as stated above.
2 Low battery due to short drives. If its a battery it will go away after 50 miles drive
Appreciate 0
      09-13-2020, 09:25 PM   #15
m3_08
Private First Class
50
Rep
161
Posts

Drives: 2021x545e, e63swagon
Join Date: May 2015
Location: ATL

iTrader: (0)

Besides malfunction I know two reasons it may happened:
1. Storm as stated above.
2 Low battery due to short drives. If its a battery it will go away after 50 miles drive
Appreciate 0
      09-15-2020, 01:20 PM   #16
mitch57
Captain
251
Rep
680
Posts

Drives: 2020 BMW X7 xDrive40i
Join Date: Oct 2019
Location: Pacific Northwest

iTrader: (0)

It could be this as well. https://static.nhtsa.gov/odi/tsbs/20...74315-9999.pdf.
Appreciate 1
      09-15-2020, 03:31 PM   #17
maxim38rus
New Member
United_States
6
Rep
26
Posts

Drives: BMW X1, X5, i3, 6GT
Join Date: Feb 2020
Location: CA

iTrader: (0)

Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors no longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Reminds me of the issue I had with my 6GT (see pictures attached). If your issue is the same, the KAFAS-unit may need replacing.
Attached Images
   
Appreciate 0
      09-15-2020, 04:40 PM   #18
RJJJ
Private First Class
16
Rep
181
Posts

Drives: 2020 BMW X6 M50i
Join Date: Aug 2019
Location: NJ

iTrader: (0)

Quote:
Originally Posted by maxim38rus View Post
Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors no longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Reminds me of the issue I had with my 6GT (see pictures attached). If your issue is the same, the KAFAS-unit may need replacing.
Yes that's what is showing on my idrive. Show long does it take to repair? Can it be done in 1 week? Thanks
Appreciate 0
      09-16-2020, 01:13 AM   #19
maxim38rus
New Member
United_States
6
Rep
26
Posts

Drives: BMW X1, X5, i3, 6GT
Join Date: Feb 2020
Location: CA

iTrader: (0)

Quote:
Originally Posted by RJJJ View Post
Quote:
Originally Posted by maxim38rus View Post
Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors no longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Reminds me of the issue I had with my 6GT (see pictures attached). If your issue is the same, the KAFAS-unit may need replacing.
Yes that's what is showing on my idrive. Show long does it take to repair? Can it be done in 1 week? Thanks
More than 40 days because the dealership managed to damage my car in the middle of the process. They broke the brackets holding the KAFAS' plastic cover and damaged the front bumper of the car. As the result, the car returned to me with the front bumper painted and the windshield replaced.

Fortunately, BMW of NA repurchased that vehicle from me.
Appreciate 0
      09-16-2020, 01:58 PM   #20
RJJJ
Private First Class
16
Rep
181
Posts

Drives: 2020 BMW X6 M50i
Join Date: Aug 2019
Location: NJ

iTrader: (0)

Quote:
Originally Posted by maxim38rus View Post
Quote:
Originally Posted by RJJJ View Post
Quote:
Originally Posted by maxim38rus View Post
Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors no longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Reminds me of the issue I had with my 6GT (see pictures attached). If your issue is the same, the KAFAS-unit may need replacing.
Yes that's what is showing on my idrive. Show long does it take to repair? Can it be done in 1 week? Thanks
More than 40 days because the dealership managed to damage my car in the middle of the process. They broke the brackets holding the KAFAS' plastic cover and damaged the front bumper of the car. As the result, the car returned to me with the front bumper painted and the windshield replaced.

Fortunately, BMW of NA repurchased that vehicle from me.
I see, thanks for the info. Seems mine have less malfunction than yours, ACC and lane departure warning still works. May not be the case whole unit is malfunction. BYW, does Marie than 40 days on repairs make sure the lemon law can kick in to have BMW repurchase the vehicle? When you get your car back it's still has defect? Thanks again
Appreciate 1
      09-16-2020, 03:37 PM   #21
maxim38rus
New Member
United_States
6
Rep
26
Posts

Drives: BMW X1, X5, i3, 6GT
Join Date: Feb 2020
Location: CA

iTrader: (0)

Quote:
Originally Posted by RJJJ View Post
Quote:
Originally Posted by maxim38rus View Post
Quote:
Originally Posted by RJJJ View Post
Quote:
Originally Posted by maxim38rus View Post
Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors no longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Reminds me of the issue I had with my 6GT (see pictures attached). If your issue is the same, the KAFAS-unit may need replacing.
Yes that's what is showing on my idrive. Show long does it take to repair? Can it be done in 1 week? Thanks
More than 40 days because the dealership managed to damage my car in the middle of the process. They broke the brackets holding the KAFAS' plastic cover and damaged the front bumper of the car. As the result, the car returned to me with the front bumper painted and the windshield replaced.

Fortunately, BMW of NA repurchased that vehicle from me.
I see, thanks for the info. Seems mine have less malfunction than yours, ACC and lane departure warning still works. May not be the case whole unit is malfunction. BYW, does Marie than 40 days on repairs make sure the lemon law can kick in to have BMW repurchase the vehicle? When you get your car back it's still has defect? Thanks again
Actually, both ACC and lane departure warnings worked for me, even with that number of errors present. That's because the system consists of multiple components that back up each other. In particular, there is a radar in the front bumper that allows ACC to work w/o KAFAS.

Regarding the repurchase, - there was, let's call it, a gentleman agreement between me and BMW of NA (no lawyers, courts or anything like this). In the first place, the car left the dealership with the problem fixed. So, BMW of NA gave two options: a) to accepts a monetary compensation for what had happened to my car; b) to repurchase the car at almost full price I had paid for it. I chose (b).
Appreciate 0
      09-16-2020, 05:05 PM   #22
RJJJ
Private First Class
16
Rep
181
Posts

Drives: 2020 BMW X6 M50i
Join Date: Aug 2019
Location: NJ

iTrader: (0)

Quote:
Originally Posted by maxim38rus View Post
Quote:
Originally Posted by RJJJ View Post
Quote:
Originally Posted by maxim38rus View Post
Quote:
Originally Posted by RJJJ View Post
Quote:
Originally Posted by maxim38rus View Post
Quote:
Originally Posted by RJJJ View Post
Today I was driving normally on highway, suddenly the car notification kicks in, the driving assistances supported was reduced. Then I noticed the blind spot monitors no longer lights up, and tried ACC, the steering assist can't work either. Later I checked affected systems, almost all active safety protection were affected...

Does anyone had the same experience? Should I go to the dealership or wait a few days to see if it's just an software bug? Thanks!
Reminds me of the issue I had with my 6GT (see pictures attached). If your issue is the same, the KAFAS-unit may need replacing.
Yes that's what is showing on my idrive. Show long does it take to repair? Can it be done in 1 week? Thanks
More than 40 days because the dealership managed to damage my car in the middle of the process. They broke the brackets holding the KAFAS' plastic cover and damaged the front bumper of the car. As the result, the car returned to me with the front bumper painted and the windshield replaced.

Fortunately, BMW of NA repurchased that vehicle from me.
I see, thanks for the info. Seems mine have less malfunction than yours, ACC and lane departure warning still works. May not be the case whole unit is malfunction. BYW, does Marie than 40 days on repairs make sure the lemon law can kick in to have BMW repurchase the vehicle? When you get your car back it's still has defect? Thanks again
Actually, both ACC and lane departure warnings worked for me, even with that number of errors present. That's because the system consists of multiple components that back up each other. In particular, there is a radar in the front bumper that allows ACC to work w/o KAFAS.

Regarding the repurchase, - there was, let's call it, a gentleman agreement between me and BMW of NA (no lawyers, courts or anything like this). In the first place, the car left the dealership with the problem fixed. So, BMW of NA gave two options: a) to accepts a monetary compensation for what had happened to my car; b) to repurchase the car at almost full price I had paid for it. I chose (b).
Thanks again for sharing. So did you just call bmw NA after you get your car back from dealer? Telling them that the car in repair for more than 30 days? Which number or email did you reach BMW NA?
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:44 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST