BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      06-14-2019, 08:47 PM   #23
LexxM3
Major
LexxM3's Avatar
Canada
857
Rep
1,468
Posts

Drives: E46M3, G05X5
Join Date: Apr 2019
Location: Waterloo, Canada

iTrader: (0)

Garage List
2019 X5  [0.00]
Quote:
Originally Posted by Tenac View Post
Quote:
Originally Posted by LexxM3 View Post
That's pretty close to my mileage :-(, although I am 40i. When was your X5 delivered?
Production Plant Spartanburg
Production Date 2018-11-27
Ok, thanks. My production was mid-late April, so pretty far away from yours — you don't drive that much, I guess :-).

That is a crazy story. Anyone else with around your production date should have it checked out preemptively.
__________________
G05 X5 x40i (04/2019 mfg, Canada) on S18A-19-11-540
Appreciate 0
      06-15-2019, 08:17 AM   #24
Tenac
Captain
Tenac's Avatar
318
Rep
710
Posts

Drives: 2019 BMW X5 50i, BMW X3 M40i
Join Date: Mar 2019
Location: AZ

iTrader: (0)

It would be interesting if anyone at all runs into this issue too.
__________________
2019 X5 50i
2019 X3 M40i
2017 Magnum X1
Appreciate 0
      06-15-2019, 09:11 AM   #25
Jgc650i
Private First Class
United_States
64
Rep
124
Posts

Drives: 2019 X5 50i
Join Date: Jun 2013
Location: NY

iTrader: (0)

Quote:
Originally Posted by Tenac View Post
Update, everything nice and clean no leaks. Repairs looks to have gone well. Software updated added some cool camera features my X5 did not have working before. As I back into the garage it will adjust to show how close I am to the wall when I first pull in. I can now set my home it actually shows up on the map now. All my settings stayed except the home screen, made those adjustments to back to normal for me. Not much time driving yet but will put some miles on it, so far happy with the repair.
You mention a software update. . . what version are you now on?
Appreciate 0
      06-15-2019, 09:34 AM   #26
TurtleBoy
Colonel
TurtleBoy's Avatar
1027
Rep
2,510
Posts

Drives: 2019 X5 40i
Join Date: Jan 2019
Location: Colorado

iTrader: (0)

Quote:
Originally Posted by Jgc650i View Post
You mention a software update. . . what version are you now on?
.48 is the latest, just had mine done on Thursday.
Appreciate 1
Tenac318.00

      06-28-2019, 09:32 PM   #27
Tenac
Captain
Tenac's Avatar
318
Rep
710
Posts

Drives: 2019 BMW X5 50i, BMW X3 M40i
Join Date: Mar 2019
Location: AZ

iTrader: (0)

UPDATE; Thought I would put this update in. Been a few hundred miles since the warranty work. No issues have returned car is running great. Weather in PHX is getting hotter and still no signs of any problems.
__________________
2019 X5 50i
2019 X3 M40i
2017 Magnum X1
Appreciate 2
gpitts208.50
TurtleBoy1027.00

      08-16-2019, 05:39 PM   #28
thrubyu
Registered
0
Rep
1
Posts

Drives: 2019 X5 5; 2018 M240; 2011 X5d
Join Date: Aug 2019
Location: Granite Bay, CA

iTrader: (0)

Same Issue Here @ 2,600 Miles

I am currently dealing with the exact same issue with my G05 (X5 50). I noticed a large puddle of yellow fluid on my garage floor. I purchased the vehicle at Niello BMW of Elk Grove. My production date was November 2018, Spartanburg Plant. I was just notified today by the dealer that both Inter Coolers need to be replaced. They have not said anything about replacing the Radiator. I am concerned what other internal damage this may have caused.
Appreciate 0
      08-16-2019, 06:18 PM   #29
Tenac
Captain
Tenac's Avatar
318
Rep
710
Posts

Drives: 2019 BMW X5 50i, BMW X3 M40i
Join Date: Mar 2019
Location: AZ

iTrader: (0)

Quote:
Originally Posted by thrubyu View Post
I am currently dealing with the exact same issue with my G05 (X5 50). I noticed a large puddle of yellow fluid on my garage floor. I purchased the vehicle at Niello BMW of Elk Grove. My production date was November 2018, Spartanburg Plant. I was just notified today by the dealer that both Inter Coolers need to be replaced. They have not said anything about replacing the Radiator. I am concerned what other internal damage this may have caused.
I'm not worried about anything else or potential. The concern the engineer stated was the material the inter cooler and radiator's are made out of is much more susceptible to corrosion than on the motor/turbo side. They only replaced those as a precaution and the fluid was the failure. I did end up doing a bit more search on this and believe the fluid mixture is NOT the same as typical cooling due to the nature of turbo heat and that is what they are cooling. There is two separate cooling systems on the 50i. Your standard engine cooling and the turbo or aux cooling. The aux fluid is a completely different mixture according the engineer who I spoke too. Knowing this I have no concern over any future issues but also have a case number now to reference say Turbo failure due to overheating.... or something like that.
__________________
2019 X5 50i
2019 X3 M40i
2017 Magnum X1
Appreciate 0
      08-17-2019, 01:12 PM   #30
cfm56d7b
Major General
United_States
1875
Rep
5,047
Posts

Drives: 2017 440i Gran Coupe & 2015 X5
Join Date: Nov 2012
Location: Orange County, CA

iTrader: (2)

This is such a good story with a satisfying ending. Thanks for sharing. Glad to learn that all is well.
Appreciate 1
Tenac318.00

      02-11-2020, 09:24 AM   #31
Tenac
Captain
Tenac's Avatar
318
Rep
710
Posts

Drives: 2019 BMW X5 50i, BMW X3 M40i
Join Date: Mar 2019
Location: AZ

iTrader: (0)

**Update**

So dealer called me back up late last week. They have a recall regarding the work I had done on the cooling system earlier this year. I dropped it back off for them to test the coolant and check for corrosion. They found corrosion so they will be replacing all the parts they did previously and flushing the system with a solution. Sadly it will take a week or two due to the parts being ordered but good note I have a nice 7 series to drive around.

Anyone else with a 50i get the recall notice??
__________________
2019 X5 50i
2019 X3 M40i
2017 Magnum X1
Appreciate 0
      02-11-2020, 09:44 AM   #32
sygazelle
Colonel
1730
Rep
2,525
Posts

Drives: 2014 328i M-Sport, 2019 X5 40i
Join Date: Sep 2010
Location: San Francisco

iTrader: (0)

Great outcome. Thanks for sharing.


Every post where they say "the part has to be shipped from Germany" makes me wonder if BMW really understand (or cares) about modern logistics. My X5 took 7 weeks to get fixed waiting for a "part to come from Germany".

Does BMW know, for example, that FedEx International PriorityŽ ships from Germany to the USA overnight to arrive the next day?

In my case, BMW paid a month rental car and paid one month of my car payment due to the wait. Wouldn't it be cheaper for them to just pay to have the part delivered via Fed Ex International Priority or any of the other international package shipping companies.
Appreciate 0
      02-11-2020, 12:10 PM   #33
DgjoX6M2016
2016 X6M, 09 E91, 11 E90 335D
DgjoX6M2016's Avatar
United_States
197
Rep
429
Posts

Drives: 2016 X6M
Join Date: Oct 2018
Location: CT

iTrader: (0)

Quote:
Originally Posted by rmorin1249 View Post
How in the he** is the wrong fluid put in at the assembly plant? Someone needs to investigate the plant in SC. Could be an issue with the wrong fluid but unlikely that only one vehicle was involved. Please keep us updated if you get additional info.
I agree. Wrong coolant seems damn near impossible. Weird.
Appreciate 0
      02-11-2020, 12:14 PM   #34
Tenac
Captain
Tenac's Avatar
318
Rep
710
Posts

Drives: 2019 BMW X5 50i, BMW X3 M40i
Join Date: Mar 2019
Location: AZ

iTrader: (0)

Quote:
Originally Posted by DgjoX6M2016 View Post
I agree. Wrong coolant seems damn near impossible. Weird.
It comes down to anti corrosion that is added to the coolant isn't enough protection and fails during high heat. So yes wrong additive mixtures can cause problems.
__________________
2019 X5 50i
2019 X3 M40i
2017 Magnum X1
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:20 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST