BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      02-08-2020, 02:05 AM   #1
Carneylad
Enlisted Member
12
Rep
31
Posts

Drives: G05 M50d, Tesla Model 3
Join Date: Jan 2020
Location: Glasgow, Scotland

iTrader: (0)

Display key died

I've had my display key (and the car it opens) for a month now. Yesterday the car was complaining that the key battery was low. I know the display key has two batteries, one for the display and one for the key. The display was showing that the battery was almost full and I could lock and unlock the car from about 100m so that seemed like there was loads of power in that battery too.

Turns out that the display was showing a false reading for the display battery and it was indeed going flat. Now it's dead and it won't charge through either a cable (tried all the cables I have and all the sockets) or wireless pad.

The key did look like it was going to restart once but failed. Now it's just a blank screen and no way to turn it on. I've held the buttons to reset it as per the manual but makes no difference. Thankfully it still locks/unlocks/starts the car.

Hopefully it'll be covered under warranty.

Also be interested if they can find out what happened it. I have one of those cars where the wireless charging pad generates orders of magnitude more heat than charge. I "charged" the key there a few time's and it always came up with a high temperature warning. iPhone X does the same. Hopefully the pad isn't killing devices...
Appreciate 0
      02-08-2020, 03:51 PM   #2
Bilajio
Private
35
Rep
85
Posts

Drives: BMW X5 G05
Join Date: Sep 2019
Location: United Kingdom

iTrader: (0)

So it's funny you should have this, as I've just gone through the same issue.

Display key completely died after about a month of the display battery dying.

Couldn't even get into the car.

I unlocked the car via iPhone through the app

Put the fob in the charging tray, it briefly came to life and display went black again, but it would allow me to start the car.

So since then, I've had in the wireless charging tray all day and still no charge.

I've plugged it into the mains with a micro usb and it's now charged up and working fully.

I found just keeping a hold of the power button (3-5 seconds) did bring it to life.
__________________
Now - G05
Previous - F32
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:39 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST