BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      11-24-2019, 05:47 PM   #1
mandomedic122
Private
United_States
22
Rep
79
Posts

Drives: BMW 2019 X5M G05, Mini 2016 S
Join Date: Oct 2014
Location: El Paso, Texas

iTrader: (0)

ISTA help with flashing Retrofit RSE Prof 6FH in G05

Hello all enthusiasts. I was wondering if anyone can help me flashing the retrofitted RSE Professional System into my G05 2019. I completed the entire retrofit, the system turns on and everything, but the HU and the RSE do not communicate. I read the faults with ISTA + and now I have a MGU HU error stating that it needs an Ethernet Security Certificate to initiate ethernet. As a consequence the MGU HU, Kombi, and Head Up display do not communicate with each other. I think this is due to me disconnecting the power supply from the MGU HU when I performed the install. I would really appreciate if anyone can chime in, and give me some advice on how to fix my issue.

Thanks

Armando
Appreciate 0
      04-17-2020, 10:52 AM   #2
Lolipop
Registered
0
Rep
1
Posts

Drives: bmw G05
Join Date: Apr 2020
Location: Moscow

iTrader: (0)

Quote:
Originally Posted by mandomedic122 View Post
Hello all enthusiasts. I was wondering if anyone can help me flashing the retrofitted RSE Professional System into my G05 2019. I completed the entire retrofit, the system turns on and everything, but the HU and the RSE do not communicate. I read the faults with ISTA + and now I have a MGU HU error stating that it needs an Ethernet Security Certificate to initiate ethernet. As a consequence the MGU HU, Kombi, and Head Up display do not communicate with each other. I think this is due to me disconnecting the power supply from the MGU HU when I performed the install. I would really appreciate if anyone can chime in, and give me some advice on how to fix my issue.

Thanks

Armando
Hello! how are you? did you solve your problem?
Appreciate 0
      06-25-2020, 10:07 PM   #3
xooler
New Member
10
Rep
21
Posts

Drives: BMW
Join Date: Dec 2016
Location: Space

iTrader: (0)

Quote:
Originally Posted by mandomedic122 View Post
Hello all enthusiasts. I was wondering if anyone can help me flashing the retrofitted RSE Professional System into my G05 2019. I completed the entire retrofit, the system turns on and everything, but the HU and the RSE do not communicate. I read the faults with ISTA + and now I have a MGU HU error stating that it needs an Ethernet Security Certificate to initiate ethernet. As a consequence the MGU HU, Kombi, and Head Up display do not communicate with each other. I think this is due to me disconnecting the power supply from the MGU HU when I performed the install. I would really appreciate if anyone can chime in, and give me some advice on how to fix my issue.

Thanks

Armando
I can help you.
Write me a PM or email to info(at)bmwneva.ru
Appreciate 0
      07-01-2020, 02:39 AM   #4
r207
Enlisted Member
7
Rep
42
Posts

Drives: 2017 BMW M3
Join Date: Nov 2017
Location: australia

iTrader: (0)

Quote:
Originally Posted by mandomedic122 View Post
Hello all enthusiasts. I was wondering if anyone can help me flashing the retrofitted RSE Professional System into my G05 2019. I completed the entire retrofit, the system turns on and everything, but the HU and the RSE do not communicate. I read the faults with ISTA + and now I have a MGU HU error stating that it needs an Ethernet Security Certificate to initiate ethernet. As a consequence the MGU HU, Kombi, and Head Up display do not communicate with each other. I think this is due to me disconnecting the power supply from the MGU HU when I performed the install. I would really appreciate if anyone can chime in, and give me some advice on how to fix my issue.

Thanks

Armando
how hard was the retrofit. do you have any sort of guide
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:04 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST