BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      06-23-2020, 09:11 AM   #1
Xeno
Major
Xeno's Avatar
232
Rep
1,270
Posts

Drives: 2019 X5 M Sport 5.0i
Join Date: Nov 2011
Location: USA

iTrader: (0)

Scroll wheel, Apple Music "Please Wait"

My dealer finally updated my FW to 3/2020/58.

One complaint was that the scroll wheel preforms as expected on everything except Apple Music. As the photo below shows, I always get the message "Please Wait".

This used to work, but when I complain about this the dealer always says the scroll wheel is working correctly. How do they come to that conclusion? Is there a way for them to test that particular feature without pairing an iPhone with Apple Music?
Attached Images
 
__________________
2019 BMW X5 xDrive 50i M Sports: ZD8/ZLS/ZMP/ZP2/ZPK/ZPX/337/ZX7/2NH
2015 BMW X5 xDrive 50i/XL/CW/DA+/EP/LP/FVS retired; 2008 X5 4.8i; 2012 X5 5.0i retired, 2004 X4 4.4i retired
R360c + EL, V1G2 + V1Driver, Uniden R7

Last edited by Xeno; 06-23-2020 at 09:51 AM..
Appreciate 0
      06-23-2020, 08:35 PM   #2
smovva
Private First Class
United_States
72
Rep
159
Posts

Drives: F25 2011 X3 3.5; G05 2019 X5
Join Date: Nov 2011
Location: Florida

iTrader: (0)

This also happens as well with an iPod Touch connected via cable to either USB port. Using a genuine apple cable lessened it but still happens often enough.

I did notice that if shuffle is turned off, it happens less. I did get better results by setting up a playlist of all the songs in alpha order with no shuffling. That playlist does not exhibit the "please wait". I have about 10K songs spread over ~60GB.

I think the car does not understand what song is served up next by the apple device if the car is on shuffle and apple device is on shuffle so its waiting for some sort of a static list and not getting it so showing "please wait" - completely speculative on my part however.
Appreciate 0
      06-23-2020, 08:58 PM   #3
Xeno
Major
Xeno's Avatar
232
Rep
1,270
Posts

Drives: 2019 X5 M Sport 5.0i
Join Date: Nov 2011
Location: USA

iTrader: (0)

Quote:
Originally Posted by smovva View Post
This also happens as well with an iPod Touch connected via cable to either USB port. Using a genuine apple cable lessened it but still happens often enough.

I did notice that if shuffle is turned off, it happens less. I did get better results by setting up a playlist of all the songs in alpha order with no shuffling. That playlist does not exhibit the "please wait". I have about 10K songs spread over ~60GB.

I think the car does not understand what song is served up next by the apple device if the car is on shuffle and apple device is on shuffle so its waiting for some sort of a static list and not getting it so showing "please wait" - completely speculative on my part however.
Thanks. I do use shuffle and your explanation fits.
__________________
2019 BMW X5 xDrive 50i M Sports: ZD8/ZLS/ZMP/ZP2/ZPK/ZPX/337/ZX7/2NH
2015 BMW X5 xDrive 50i/XL/CW/DA+/EP/LP/FVS retired; 2008 X5 4.8i; 2012 X5 5.0i retired, 2004 X4 4.4i retired
R360c + EL, V1G2 + V1Driver, Uniden R7
Appreciate 0
      06-24-2020, 07:20 AM   #4
Xeno
Major
Xeno's Avatar
232
Rep
1,270
Posts

Drives: 2019 X5 M Sport 5.0i
Join Date: Nov 2011
Location: USA

iTrader: (0)

I used an AM playlist without shuffle and the scroll wheel worked as expected.
__________________
2019 BMW X5 xDrive 50i M Sports: ZD8/ZLS/ZMP/ZP2/ZPK/ZPX/337/ZX7/2NH
2015 BMW X5 xDrive 50i/XL/CW/DA+/EP/LP/FVS retired; 2008 X5 4.8i; 2012 X5 5.0i retired, 2004 X4 4.4i retired
R360c + EL, V1G2 + V1Driver, Uniden R7
Appreciate 0
      06-25-2020, 08:44 PM   #5
thereef510
Captain
United_States
327
Rep
798
Posts

Drives: '16 F15; '20 G05
Join Date: Apr 2019
Location: Tennessee

iTrader: (0)

While I no longer have Apple Music, I still have all of my music preloaded onto my iphone X. This happens every now and then. The only consistent fix I've found is to disconnect CarPlay and switch it back to idrive then reconnect it to carplay. It's annoying but it always fixes the issue.
Appreciate 0
      06-27-2020, 10:09 AM   #6
smovva
Private First Class
United_States
72
Rep
159
Posts

Drives: F25 2011 X3 3.5; G05 2019 X5
Join Date: Nov 2011
Location: Florida

iTrader: (0)

Quote:
Originally Posted by Xeno View Post
I used an AM playlist without shuffle and the scroll wheel worked as expected.
Good to know, thanks for confirming!
Appreciate 0
      07-02-2020, 04:36 PM   #7
adamcb
Enlisted Member
adamcb's Avatar
United_States
5
Rep
39
Posts

Drives: '20 X5 M5.0, '12 335is Cabrio
Join Date: Aug 2009
Location: Austin, TX USA

iTrader: (0)

I've had this issue too on my 2020 X5 M50i running 11/2020/70.

I've found that 90% of the time when I reset my iPhone (power down, power up), it starts to work again. Only happened a few times.

The remaining 10% of the time, it's usually remedied by doing the iDrive reset (holding power button in for 20-30 secs).

Good luck,

Adam
Appreciate 0
      07-02-2020, 04:55 PM   #8
Xeno
Major
Xeno's Avatar
232
Rep
1,270
Posts

Drives: 2019 X5 M Sport 5.0i
Join Date: Nov 2011
Location: USA

iTrader: (0)

Quote:
Originally Posted by adamcb View Post
I've had this issue too on my 2020 X5 M50i running 11/2020/70.

I've found that 90% of the time when I reset my iPhone (power down, power up), it starts to work again. Only happened a few times.

The remaining 10% of the time, it's usually remedied by doing the iDrive reset (holding power button in for 20-30 secs).

Good luck,

Adam
Just to clarify so are you saying these resets then allow your you wheel in the HUD to scroll even when using the shuffle feature of Apple Music?
__________________
2019 BMW X5 xDrive 50i M Sports: ZD8/ZLS/ZMP/ZP2/ZPK/ZPX/337/ZX7/2NH
2015 BMW X5 xDrive 50i/XL/CW/DA+/EP/LP/FVS retired; 2008 X5 4.8i; 2012 X5 5.0i retired, 2004 X4 4.4i retired
R360c + EL, V1G2 + V1Driver, Uniden R7
Appreciate 0
      07-02-2020, 05:00 PM   #9
adamcb
Enlisted Member
adamcb's Avatar
United_States
5
Rep
39
Posts

Drives: '20 X5 M5.0, '12 335is Cabrio
Join Date: Aug 2009
Location: Austin, TX USA

iTrader: (0)

Xeno, these resets seemed to fix the "please wait" error that I was constantly getting when trying to use the scroll wheel on the steering wheel.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:18 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST