BMW X5
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Post Reply
 
Thread Tools Search this Thread
      11-26-2021, 07:03 PM   #1
10101X5
Lieutenant
317
Rep
528
Posts

Drives: 10101X101
Join Date: Oct 2012
Location: USA

iTrader: (0)

Mileage on myBMW

How accurate is this? Does anyone know how often it gets updated? I thought it would update everytime engine is started but apparently not. Itís about 500 off the actual mileage. Is it just mine?
Appreciate 0
      11-26-2021, 07:30 PM   #2
goobies818
Second Lieutenant
129
Rep
219
Posts

Drives: BMW X5 M50i
Join Date: Sep 2021
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by 10101X5 View Post
How accurate is this? Does anyone know how often it gets updated? I thought it would update everytime engine is started but apparently not. Itís about 500 off the actual mileage. Is it just mine?
Are you talking about the estimated range left in the tank and miles driven shown on the app?

From my experienceÖthe app updates/refreshes shortly after logging inÖitís not accurate the moment you just log inÖmaybe some connectivity issues from where youíre trying to log in?
Appreciate 0
      11-26-2021, 08:03 PM   #3
nZtiZia
Brigadier General
nZtiZia's Avatar
United_States
1514
Rep
3,176
Posts

Drives: eVeRyOnE mAD!
Join Date: Dec 2020
Location: neither here nor there...

iTrader: (0)

Garage List
ofttimes it's server related, but have you checked your Data Privacy settings? there have been a couple updates recently, and it defaults to NO SERVICE which results in no communication with the server. unfortunately, the lack of app updates can be due to various reasons often requiring different things to remedy.
Attached Images
 
Appreciate 0
      11-26-2021, 09:23 PM   #4
10101X5
Lieutenant
317
Rep
528
Posts

Drives: 10101X101
Join Date: Oct 2012
Location: USA

iTrader: (0)

Itís the actual mileage of the car, not the range. I do have first box checked. So are they matched on yours?
Appreciate 0
      11-26-2021, 11:58 PM   #5
nZtiZia
Brigadier General
nZtiZia's Avatar
United_States
1514
Rep
3,176
Posts

Drives: eVeRyOnE mAD!
Join Date: Dec 2020
Location: neither here nor there...

iTrader: (0)

Garage List
Quote:
Originally Posted by 10101X5 View Post
It’s the actual mileage of the car, not the range. I do have first box checked. So are they matched on yours?
matched between what's displayed on the app and the instrument cluster? yes.

so yours is 500 miles 'off'? let me guess: the mileage on your app is 500 less than what's seen in the car? can you take a screenshot of the mileage you're referring to on your app?
Appreciate 0
      11-27-2021, 08:59 AM   #6
10101X5
Lieutenant
317
Rep
528
Posts

Drives: 10101X101
Join Date: Oct 2012
Location: USA

iTrader: (0)

Yes it’s behind the actual mileage. I just checked again and noticed it’s not actually behind but has been stuck at that number. I also noticed the vehicle’s location under vehicle finder has been stuck too. I guess it started happening about 500 miles ago that I wasn’t aware of. Another thing that I’ve never been able to get to work is the 360 view. I never actually used this until I saw a post here and curious what it shows. I guess all these might have started when I updated the iOS and noticed the phone key no longer works fully. I did update the app but nothing changed.
Attached Images
 
Appreciate 0
      11-27-2021, 09:08 AM   #7
allinon72
Colonel
allinon72's Avatar
United_States
3182
Rep
2,865
Posts

Drives: 22' X5 45e, 20' X3MC
Join Date: May 2017
Location: Indianapolis, IN

iTrader: (1)

The same thing happened to me - I called the genius line and they had me select "update all apps" in iDrive, reboot iDrive by holding the volume knob in for 30 seconds, and uninstall and reinstall the phone app. That solved the problem. My hunch is reinstalling the phone app is what actually did it.
Appreciate 1
10101X5317.00
      11-27-2021, 09:21 AM   #8
nZtiZia
Brigadier General
nZtiZia's Avatar
United_States
1514
Rep
3,176
Posts

Drives: eVeRyOnE mAD!
Join Date: Dec 2020
Location: neither here nor there...

iTrader: (0)

Garage List
Quote:
Originally Posted by 10101X5 View Post
I guess all these might have started when I updated the iOS and noticed the phone key no longer works fully. I did update the app but nothing changed.
a few things u can try:
1) logout then login to app
2) uninstall then reinstall app then login
3) telematics reboot of iDrive (hold down VOL button for 3 reboots ~70-90 seconds)
4) remove driver profile then add it again
Appreciate 1
10101X5317.00
      11-27-2021, 01:57 PM   #9
10101X5
Lieutenant
317
Rep
528
Posts

Drives: 10101X101
Join Date: Oct 2012
Location: USA

iTrader: (0)

Thanks for the suggestions. Update... I did the following steps.
Logging out logging in. Did not do it
Uninstalling/re-installing app. Did not do it.
Rebooting iDrive (30s). Did it.
I wonder if rebooting iDrive was all it would take. In any case I love this car but these not fully tested features/options are rather annoying.
Appreciate 1
nZtiZia1513.50
      11-27-2021, 02:55 PM   #10
nZtiZia
Brigadier General
nZtiZia's Avatar
United_States
1514
Rep
3,176
Posts

Drives: eVeRyOnE mAD!
Join Date: Dec 2020
Location: neither here nor there...

iTrader: (0)

Garage List
Quote:
Originally Posted by 10101X5 View Post
Rebooting iDrive (30s). Did it.
I wonder if rebooting iDrive was all it would take. In any case I love this car but these not fully tested features/options are rather annoying.
rebooting iDrive is actually the most recommended initial intervention when faced with an issue. it's akin to restarting one's computer or phone when things get buggy or glitchy. modern cars are computers on wheels lol

Last edited by nZtiZia; 11-27-2021 at 03:01 PM..
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:27 AM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST